Closed Bug 1599078 Opened 2 years ago Closed 1 year ago

[meta] Redesign session history in the parent to work without synchronous IPC

Categories

(Core :: DOM: Navigation, task, P3)

task

Tracking

()

RESOLVED DUPLICATE of bug 1467221

People

(Reporter: peterv, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: meta)

Bug 1438272 moved most of the session history data into the parent process (if the fission.sessionHistoryInParent pref is set). We access the data with XPCOM APIs implemented using synchronous IPC, which we need to get rid off.

Depends on: 1599085
Priority: -- → P3
Depends on: 1599093

Let's just use bug 1467221 as the main meta bug.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: fission-history
You need to log in before you can comment on or make changes to this bug.