Closed Bug 1599177 Opened 1 year ago Closed 1 year ago

Watchpoints - After click Refresh option JS execution cannot pause anymore

Categories

(DevTools :: Debugger, defect, P3)

Desktop
Unspecified
defect

Tracking

(firefox-esr68 unaffected, firefox71 unaffected, firefox72 verified, firefox73 verified)

VERIFIED FIXED
Firefox 73
Tracking Status
firefox-esr68 --- unaffected
firefox71 --- unaffected
firefox72 --- verified
firefox73 --- verified

People

(Reporter: marcela.calderon, Assigned: jlast)

References

(Blocks 1 open bug)

Details

Attachments

(3 files, 1 obsolete file)

Attached video Refresh_Not_works.mp4

After watchpoint property set is created, if the user click on Refresh button, JS execution stop working

Affected versions
Firefox versions Nightly 72.0a1

Affected platforms
Windows 10

Steps to reproduce

  1. Launch the RTL Firefox Browser and open http://janodvarko.cz/tests/debugger/watchpoints/
  2. Open Developer Tools and click on "Click Me!" button in Test Case #!
  3. On Scopes Side Panel looks for object and add watchpoint (property set or get)
  4. Click on refresh button
  5. Click on "Click Me!" button

Actual Result
JS cannot pause anymore. It seems like the watchpoint has not been removed (See attachment "Refresh_Not_works_1.mp4")

Note
If the user first click on "Resume" button, after click Refresh option, "Click Me!" works ok and JS execution is paused.

Attached video Refresh_Not_works_1.mp4
Hardware: Unspecified → Desktop
Duplicate of this bug: 1586904

Confirming that I can easily reproduce the issue on my machine (Win10, Fx Nightly)

Reopening the Toolbox is not enough to fix the issue (the Debugger doesn't properly updates its UI when pausing JS execution).
I had to restart Firefox to be able to properly pause JS execution again.

Honza

Assignee: nobody → jlaster
Attachment #9113917 - Attachment is obsolete: true
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/10160518ddc8
Watchpoints -  After click Refresh option JS execution cannot pause anymore. r=bhackett
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 73

Verified fixed on lates Nightly Version 73.0a1 Build ID 20191208213628 on Windows 10, macOS 10.14 and Ubuntu 18.04

Comment on attachment 9113892 [details]
Bug 1599177 - Watchpoints - After click Refresh option JS execution cannot pause anymore. r=jaril

Beta/Release Uplift Approval Request

  • User impact if declined: Watchpoints (new debugger feature) will stop working if the user refreshes the page while paused because of a watchpoint.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): it only affects the debugger.
  • String changes made/needed:
Attachment #9113892 - Flags: approval-mozilla-beta?

Comment on attachment 9113892 [details]
Bug 1599177 - Watchpoints - After click Refresh option JS execution cannot pause anymore. r=jaril

debugger fix, approved for 72.0b5

Attachment #9113892 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified fixed on Beta Version 72.0b5 Build ID 20191210230245 on Windows 10, macOS 10.14 and Ubuntu 18.04

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.