Closed Bug 1599215 Opened 1 year ago Closed 1 year ago

Watchpoints - Property SET/GET not works as expected after close Dev Tools

Categories

(DevTools :: Debugger, defect, P3)

Desktop
Unspecified
defect

Tracking

(firefox72 verified, firefox73 verified)

VERIFIED FIXED
Firefox 73
Tracking Status
firefox72 --- verified
firefox73 --- verified

People

(Reporter: marcela.calderon, Assigned: jlast)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

After Dev Tools is closed, watchpoints property set/get does not work as expected.

Affected versions
Firefox versions Nightly 72.0a1

Affected platforms
Windows 10

Steps to reproduce

  1. Launch the Firefox Browser and open http://janodvarko.cz/tests/debugger/watchpoints/
  2. Open Developer Tools and click on "Click Me!" button in Test Case #!
  3. On Scopes Side Panel looks for object Person.age and add watchpoint property set
  4. Close Dev Tools and reopen again
  5. Click on "Click Me!" button in Test Case #! and looks for watchpoint

Actual Result
Person.age value displays a symbol >> with Tooltip (Invoke getter) instead of the original value (number)

Note
For property Get, if you click on ">>", value "Restricted" is displayed.
For property Set, if you click on ">>", value 36 is displayed

Hardware: Unspecified → Desktop

Thanks for the report Marcela!

Yes, I can reproduce the problem as well:

Here are my extended STRs:

  1. Launch the Firefox Browser and open http://janodvarko.cz/tests/debugger/watchpoints/
  2. Open Developer Tools and click on "Click Me!" button in Test Case #!
  3. On Scopes Side Panel looks for object Person.age and add watchpoint property set
  4. Resume the execution and see that the watchpoint properly hits on line 12
  5. Close Dev Tools and reopen again
  6. Click on "Click Me!" button in Test Case #! and looks for watchpoint
  7. On Scopes Side Panel looks for object Person.age . It doesn't show the value, but an icon >> to manualy invoke the getter. The set watchpoint can be created at this point, but it won't work => BUG
  8. Try to invoke the getter by clicking on >>
  9. Add watchpoint property set
  10. Resume execution, the watchpoint doesn't work => BUG

Honza

Priority: -- → P3
Assignee: nobody → jlaster
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/87ee29f02a88
Watchpoints do not work as expected after close Dev Tools. r=bhackett
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 73

Verified fixed on lates Nightly Version 73.0a1 Build ID 20191208213628 on Windows 10, macOS 10.14 and Ubuntu 18.04

Comment on attachment 9113916 [details]
Bug 1599215 - Watchpoints do not work as expected after close Dev Tools. r=jaril

Beta/Release Uplift Approval Request

  • User impact if declined: Watchpoints (new debugger feature) will stop working if the user closes devtools while paused because of a watchpoint.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This only affects the debugger.
  • String changes made/needed:
Attachment #9113916 - Flags: approval-mozilla-beta?

(In reply to Jason Laster [:jlast] from comment #7)

  • Why is the change risky/not risky? (and alternatives if risky): This only affects the debugger.

FWIW this is as much an argument against taking a patch than for it. It'd help to be more specific.

(In reply to Jason Laster [:jlast] from comment #7)

  • Is this code covered by automated tests?: Yes

The tests didn't catch this bug though, and the fix doesn't touch tests. I don't suppose that could be addressed?

Flags: qe-verify+

Comment on attachment 9113916 [details]
Bug 1599215 - Watchpoints do not work as expected after close Dev Tools. r=jaril

debugger fix, approved for 72.0b5

Attachment #9113916 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Verified fixed on Beta Version 72.0b5 Build ID 20191210230245 on Windows 10, macOS 10.14 and Ubuntu 18.04

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.