Closed Bug 1599301 Opened 3 years ago Closed 2 years ago

Switch mail window to use type="folder" instead of rdf templates

Categories

(SeaMonkey :: MailNews: Message Display, task)

task
Not set
normal

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53 fixed, seamonkey2.57esr fixed)

RESOLVED FIXED
seamonkey 2.71
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 --- fixed
seamonkey2.57esr --- fixed

People

(Reporter: iannbugzilla, Assigned: iannbugzilla)

References

Details

(Whiteboard: SM2.53.1)

Attachments

(1 file, 2 obsolete files)

At the moment mailWindowOverlay and folderPane/mailWidgets use rdf templates to populate folderpickers, we should switch to using menupopup type="folder" from folderWidgets.xml.
This patch does make a change to the Go menu in that the folders now sit as submenu rather than being in a main menu, thus an extra click away but looks tidier and allows the menu to be easily hidden in a standalone message window.
This also ports relevant changes from Bug 439291 (thunderbird doesn't have the account/folder list under the Go menu).

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: None
Testing completed (on m-c, etc.): 2.53
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch: Two new entities in messenger.dtd

Attachment #9111451 - Flags: review?(frgrahl)
Attachment #9111451 - Flags: approval-comm-release?
Attachment #9111451 - Flags: approval-comm-esr60?
Blocks: 1599501

Needed to update the MsgMoveMessage/MsgCopyMessage callers/functions too.

Attachment #9111451 - Attachment is obsolete: true
Attachment #9111451 - Flags: review?(frgrahl)
Attachment #9111451 - Flags: approval-comm-release?
Attachment #9111451 - Flags: approval-comm-esr60?
Attachment #9112504 - Flags: review?(frgrahl)
Attachment #9112504 - Flags: approval-comm-release?
Attachment #9112504 - Flags: approval-comm-esr60?

Added SelectMsgFolder function for goFolderMenu to use - could be used elsewhere but want to land other folderPane work first.

Attachment #9112504 - Attachment is obsolete: true
Attachment #9112504 - Flags: review?(frgrahl)
Attachment #9112504 - Flags: approval-comm-release?
Attachment #9112504 - Flags: approval-comm-esr60?
Attachment #9112562 - Flags: review?(frgrahl)
Attachment #9112562 - Flags: approval-comm-release?
Attachment #9112562 - Flags: approval-comm-esr60?
Comment on attachment 9112562 [details] [diff] [review]
Switch to use folderWidgets type="folder" v1.2

LGTM
Attachment #9112562 - Flags: review?(frgrahl)
Attachment #9112562 - Flags: review+
Attachment #9112562 - Flags: approval-comm-release?
Attachment #9112562 - Flags: approval-comm-release+
Attachment #9112562 - Flags: approval-comm-esr60?
Attachment #9112562 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/20be22b77f86
Switch mail window to use type="folder" instead of rdf templates. r=frg

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey 2.71
You need to log in before you can comment on or make changes to this bug.