Closed Bug 1599327 Opened 3 months ago Closed 1 month ago

Use cluster scrollbar flags to select picture cache tile size.

Categories

(Core :: Graphics: WebRender, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla74
Tracking Status
firefox74 --- fixed

People

(Reporter: gw, Assigned: bpeers)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

The picture cache code selects an appropriate tile size to use by considering the size of the content rectangle [1].

We only ever want to create small sized tiles for real scrollbars.

When we decide to create a picture for a scrollbar, it's based on the presence of a tag in the primitive cluster flags [2].

Instead of basing this decision on size, we could propagate those cluster flags when creating the TileCacheInstance. Then, we could only select a scrollbar tile size if this picture has been tagged as a scrollbar.

[1] https://searchfox.org/mozilla-central/rev/0678172d5b5c681061b904c776b668489e3355b0/gfx/wr/webrender/src/picture.rs#1678

[2] https://searchfox.org/mozilla-central/rev/0678172d5b5c681061b904c776b668489e3355b0/gfx/wr/webrender_api/src/display_item.rs#43

Blocks: wr-intro
Assignee: nobody → bpeers

This looks like the perfect excuse to get familiar with picture.rs tile caching :)

Pushed by bpeers@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1bd9d4f431c4
Use cluster scrollbar flags to select picture cache tile size. r=gw

Confirmed with [:gw] that failure is benign, so I created a new reference image for the failing test and re-landed the change with the image.

Flags: needinfo?(bpeers)
Pushed by bpeers@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2b3093f69e87
Use cluster scrollbar flags to select picture cache tile size. r=gw
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
Regressions: 1601865
Regressions: 1601924
Regressions: 1602500

I'm asking for a backout; between the issue of scrollbar clusters not being on a slice by themselves, and now flickering black squares, I don't think I'll be able to resolve these fast enough.

Backed out for causing bugs 1601865, 1601924, 1602500

Backout: https://hg.mozilla.org/integration/autoland/rev/f47661feecce9b319848f7d77202cfa67334be8f

Status: RESOLVED → REOPENED
Flags: needinfo?(bpeers)
Resolution: FIXED → ---
Target Milestone: mozilla73 → ---

Thanks Andreea!

Flags: needinfo?(bpeers)

(In reply to Bert Peers [:bpeers] from comment #11)

Thanks Andreea!

Any time!

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:bpeers, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(bpeers)

It landed, but was backed out, not sure what the bot wants me to do. Clearing NMI.

Flags: needinfo?(bpeers)
Pushed by bpeers@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/269ab6499d32
Use cluster scrollbar flags to select picture cache tile size. r=gw
Status: REOPENED → RESOLVED
Closed: 3 months ago1 month ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74
You need to log in before you can comment on or make changes to this bug.