Closed Bug 1599543 Opened 8 months ago Closed 7 months ago

Saving complete page locally does not download the background-image of one <div>

Categories

(Firefox :: File Handling, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 115107
Tracking Status
firefox70 --- affected
firefox71 --- affected
firefox72 --- affected

People

(Reporter: erik.dobak, Unassigned)

Details

Attachments

(1 file)

94.43 KB, image/png
Details
Attached image wtf.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

open supersonico.eu
in menu bar (that i always have to enable) choose file/save page as
save the page
open the page as file in FF

Actual results:

you can see that on the bottom that yellow oscilo curve is represented by a blank white rectangle.

Expected results:

you should have seen a hand written curve with yellow background.

Confirming.

(On a side note, inserting lots of <br> instead of a proper div is pretty bad HTML code.)

Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: save page corrupts a part of my page → Saving complete page locally does not download the background-image of one <div>
Version: 68 Branch → 70 Branch

add lots of <br> : you are welcome to enjoy my punk html from the 90ties. also i did use </br> as i am not an barbarian.

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Hi,

I have managed to reproduce this issue on latest FF release 70.0.1, Beta 71 and latest Nightly build 72.0a1 (2019-12-01) using Ubuntu 18.04 and Windows 10.
Further, I will move this over to a component so developers can take a look over it. If this is not the correct component please feel free to change it to an appropriate one.
Note that the issue is also reproducible on Chrome.

Thanks for the report.

Component: Untriaged → File Handling
OS: Unspecified → All
Hardware: Unspecified → All
Version: 70 Branch → Trunk

it seems that <div style="background-image:url(sinus_for_women.jpg);"> is completely ignored when saving the page:

  1. .jpg is not saved in the "files" folder
  2. the "files" folder is not prefixing the .jpg in the saved page.

ps: i also noticed that my page contains </br> which are saved as <br> but that would be another bug..

Suspect dupe of bug 115107

Yeah, this is a known issue.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 115107
You need to log in before you can comment on or make changes to this bug.