Closed Bug 1599616 Opened 11 months ago Closed 4 days ago

Fix web browser persist toolkit/components/windowcreator/test/browser_bug1204626.js for Fission

Categories

(Core :: Window Management, task, P2)

task

Tracking

()

RESOLVED FIXED
84 Branch
Fission Milestone M6c
Tracking Status
firefox72 --- wontfix
firefox81 --- affected
firefox84 --- fixed

People

(Reporter: cpeterson, Assigned: farre, NeedInfo)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

Fails in opt: NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWebBrowserPersist.saveDocument]

Skipped in debug.

Type: defect → task

Neil, this bug is a blocker for Fission's current milestone (M4.1 aka "fix all the mochitests"), but it's currently unassigned. The Fission team is hoping teams will fix their mochitests for Fission before the end of Q1 (75 or 76 Nightly).

Will your team be able to prioritize this bug for Q1? If you don't think this mochitest failure should block shipping Fission, just let me know

If you have questions for Fission engineers, you can reach them in the #fission channel on Slack or Riot.

Flags: needinfo?(enndeakin)

Well this bug is really just 'fix web browser persist' for fission, which I suspect would be a large amount of work. Perhaps Jed who wrote this for e10s could comment on how involved this would be.

My understanding is that this not working would prevent saving web pages (File -> Save Page As)

I guess we should file a proper separate bug though on fixing this.

Flags: needinfo?(enndeakin) → needinfo?(jld)

(In reply to Neil Deakin from comment #2)

My understanding is that this not working would prevent saving web pages (File -> Save Page As)

We have bug 1576188 for fixing "Save Page As" for Fission.

Blocks: 1576188
Summary: Fix toolkit/components/windowcreator/test/browser_bug1204626.js in Fission mode → Fix web browser persist toolkit/components/windowcreator/test/browser_bug1204626.js for Fission

I haven't touched WebBrowserPersist for years, but bug 1576188 comment #2 seems to be a pretty good summary of the problem. You'd probably have more luck asking someone from the DOM team.

Flags: needinfo?(jld)

(In reply to Jed Davis [:jld] ⟨⏰|UTC-7⟩ ⟦he/him⟧ from comment #4)

You'd probably have more luck asking someone from the DOM team.

Sending this bug back to Fission triage to find an appropriate DOM contact.

Fission Milestone: M4.1 → ?

duping to "Save Page As" bug 1576188

Status: NEW → RESOLVED
Fission Milestone: ? → ---
Closed: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1576188

@ farre: I originally closed this bug as a dupe of "Save Page As" bug 1576188, which you fixed, but this browser_bug1204626.js test is still annotated as failing on Fission opt and skipped Fission debug. Can we re-enable this test now that you've fixed bug 1576188?

https://searchfox.org/mozilla-central/rev/7ec7ee4a9bde171ba195ab46ed6077e4baaef34d/toolkit/components/windowcreator/test/browser.ini#1-3

Status: RESOLVED → REOPENED
Fission Milestone: --- → M4.1
Flags: needinfo?(afarre)
Resolution: DUPLICATE → ---
Assignee: nobody → afarre
Flags: needinfo?(afarre)

Kashav has a patch in bug 1653674 to try re-enabling this test.

Depends on: 1653674

So, it works fine on my machine, so re-enabling should just work. bug 1653674 comment 3 feels strange, it should just work. Is there a try run somewhere?

(In reply to Andreas Farre [:farre] from comment #9)

So, it works fine on my machine, so re-enabling should just work. bug 1653674 comment 3 feels strange, it should just work. Is there a try run somewhere?

So it turns out it also fails in debug builds (very?) intermittently. There's some logs in bug 1620954 comment 15.

Oops, looks like those are all unexpected passes. This can probably be re-enabled everywhere.

Pushed by afarre@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/673f1a12e21a
Enable browser_bug1204626.js for Fission. r=kashav
Status: REOPENED → RESOLVED
Closed: 8 months ago3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
Status: RESOLVED → REOPENED
Flags: needinfo?(afarre)
Resolution: FIXED → ---
Target Milestone: 81 Branch → ---
Fission Milestone: M4.1 → M6b
Fission Milestone: M6b → M6c
Flags: needinfo?(afarre)

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:farre, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(afarre)
Pushed by afarre@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b631c11d4acf
Don't try to save document when document actor has been destroyed. r=smaug
Status: REOPENED → RESOLVED
Closed: 3 months ago4 days ago
Resolution: --- → FIXED
Target Milestone: --- → 84 Branch
Attachment #9167334 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.