Closed Bug 1599693 Opened 2 months ago Closed 2 months ago

Search using <search engine set as default>" tooltip is not shown on search bar

Categories

(Firefox :: Search, defect, P1)

defect
Points:
1

Tracking

()

VERIFIED FIXED
Firefox 73
Iteration:
73.1 - Dec 2 - Dec 15
Tracking Status
firefox70 --- unaffected
firefox71 + wontfix
firefox72 --- verified
firefox73 --- verified

People

(Reporter: alin.ilea, Assigned: standard8)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Affected versions:

Nightly 72.0a1 (2019-11-26), Beta 71.

Affected platforms:

Windows 7, Windows 10, Ubuntu 16, Mac OS 10.15

Steps:

  1. Launch Firefox and enable the search bar from about:preferences#search by clicking on "Add search bar in toolbar" option.
  2. Hover the mouse over the Search Bar.

Actual result:

"Search using <search engine set as default>" is not shown as tooltip.

Expected result:

"Search using <search engine set as default>" tooltip should be displayed.

Regression range:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=04da00a61c6df437250e3af0d20f8ec72bbe9f48&tochange=9596d7f4a7457bccc78cadf9c39bcc9c4b5b97f8

Looks like this was most likely caused by bug 1534455.

Assignee: nobody → standard8
Iteration: --- → 73.1 - Dec 2 - Dec 15
Points: --- → 1
Keywords: regression
Priority: -- → P1
Regressed by: 1534455
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9e4f4e3cb56d
Fix 'Search using <engine name>' tooltip on the search bar. r=ntim.
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 73

Comment on attachment 9113215 [details]
Bug 1599693 - Fix 'Search using <engine name>' tooltip on the search bar. r?ntim.

Beta/Release Uplift Approval Request

  • User impact if declined: Missing tooltip for searchbar, which also isn't great for screen reader users.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See comment 0
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): straightforward JS patch
  • String changes made/needed: none
Attachment #9113215 - Flags: approval-mozilla-release?
Attachment #9113215 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Verified - fixed on latest Nightly 73.0a1 (2019-12-03) (Build id: 20191203215345) on Mac OS 10.14 , Windows 10 and Ubuntu 18.04

Comment on attachment 9113215 [details]
Bug 1599693 - Fix 'Search using <engine name>' tooltip on the search bar. r?ntim.

simple fix for a recent regression, approved for 72.0b3

Attachment #9113215 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified - fixed on latest Beta 72.0b3 (Build id: 20191204104712) on Mac OS 10.14 , Windows 10 and Ubuntu 18.04

Adding this to list of possible ride-alongs in case we have a dot release driver.

Comment on attachment 9113215 [details]
Bug 1599693 - Fix 'Search using <engine name>' tooltip on the search bar. r?ntim.

This is probably not happening now we're getting close to holidays with 72 right after.

Attachment #9113215 - Flags: approval-mozilla-release? → approval-mozilla-release-
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.