If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

While working offline, Mozilla Mail doesn't send receipts

RESOLVED DUPLICATE of bug 140477

Status

MailNews Core
Backend
RESOLVED DUPLICATE of bug 140477
15 years ago
9 years ago

People

(Reporter: Ivan Misuno, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Steps to reproduce:
1. Enable "Allow return receipts" option in Preferences/Mail&Newsgroups/Return
receipts tab
2. Receive any mail message with "return receipt" request, but do not select it
3. Go offline
4. Select message. A "Receipt is requested for this message" message box will
appear.
5. Click OK button.

Actual results:
Nothing happens - receipt neither is sent back, nor placed to "unsent messages"
folder

Result is the same when internet connection is no longer available. After
selectiong OK to send return receipt, nothing happens.

Expected results:
The return receipt should have been placed to "Unsent messages" folder, so that
when gone online again, it could have been sent.

Additional feature, allowing read receipts be placed to "Unsent messages"
folder, instead of being sent immediately, would be good.

Comment 1

15 years ago
Reporter,
what is your build Id?

I tried your steps to reproduce and I didn't see prompt
to send a return receipt back. But you are right that
we won't send a return receipt while offline or when we
go back online.

This bug is even in the old 4.x code. 

In both cases, the return receipt mesg back to originator does not
get stored in 'unsent mesgs'folder while offline. Hence no
return receipt sent when you go back online.

But I am not sure we can even 'store it' in unsent folder as I
think it's automatically sent back and not a true compose mesg.

And it's possible it might not be a true bug. Maybe one of the
requirements is that you have to be online? Don't know.



Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

15 years ago
I also think, this is a bug. My suggestion is: put the receipts into the Unsent
Messages folder as a normal message. Then, the user can delete receipts if he
prepares a useful reply to the recipient (you know, if you download mails, you
may prepare replies to them for the next online time, and then the receipt is
quite useless, because the sender gets it together with a real reply:)). This
could even be done automatically. I don't see a big problem in this, because the
receipt is already generated (I found it in windows/temp) but seems not to be
used in any way. If it can't be done, then mention it in the help:)
And you can change the OS of this bug to Win95, or probably all platforms:)
Product: Browser → Seamonkey

Comment 3

11 years ago
This is definatly a bug.
I just read this post and it's exactly my problem!

The also is a file (mdnmsg) in my "TEMP" folder, which contains the receipt.

The big questions are:
IS THERE ALREADY A FIX FOR THAT BUG?
ARE THERE ANY OTHER POSSIBILITIES?
HOW DO YOU HANDLE THIS PROB, OR DID YOU JUST UNINSTALL TB?
IS THERE ANY Add-Ons FOR TB, THAT GIVES A ALTERNATIVE?

Updated

10 years ago
Assignee: jt95070 → nobody
Component: MailNews: Return Receipts → MailNews: Backend
OS: Windows 2000 → All
Product: Mozilla Application Suite → Core
QA Contact: grylchan → backend
Hardware: PC → All

Updated

10 years ago
Duplicate of this bug: 386196

Comment 5

10 years ago
Xref bug 140477

Comment 6

10 years ago
this problem is very problematic from roaming peoples in professional use.
the code from send the mdm (nsIMsgMdnGenerator) always return OK and can t be checked in the javascript code
it seem that it will better to send the MDN by the normal way like a normal message for stock it in the unsent Message folder
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core

Comment 7

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.2pre) Gecko/2008072418 Thunderbird/3.0a2 ID:2008072418

confirming this as presented [for pop and for imap]. 

It does seam ok when hit ok but actually nothing happens. Can be considered sort of data loss where one is not even able to later do that again. (workaround is another mail sent or, well, the phone)

Comment 8

9 years ago
Rereadig i think this is a dupe. Sending MDNs offline doesn't work.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 140477
You need to log in before you can comment on or make changes to this bug.