Closed Bug 1599974 Opened 10 days ago Closed 10 days ago

Break on attribute modification when style attributes values are changed

Categories

(DevTools :: Debugger, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1577911

People

(Reporter: karlcow, Unassigned)

Details

  1. Go to Google Maps https://maps.google.com/
  2. Open the inspector
  3. Open the contextual when selecting the body element
  4. Choose "Break On…"
  5. Select "Attribute Modification"
  6. Resize the window

Actual:
Nothing is happening

Expected:
breaks where the script is updating the values of the style element.

Google maps has a style attribute. Values are changed when the window is resized.
I didn't check if it was happening for other attributes values or if it's only style, I'll try to check.

Rationale for priority:
More and more applications are using CSS-in-JS which are dynamically adjusting the style for every interactions.

<body 
    class="keynav-mode-off screen-mode" 
    tabindex="-1" jstcache="0" 
    style="width: 669px; height: 695px;"> 
…
</body>

oh wait This is a duplicate of Bug 1577911

Status: NEW → RESOLVED
Closed: 10 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1577911
You need to log in before you can comment on or make changes to this bug.