Closed Bug 1600048 Opened 10 months ago Closed 10 months ago

[Clang-Tidy] Json exporter is broken

Categories

(Firefox Build System :: Source Code Analysis, defect, P1)

defect

Tracking

(firefox-esr68 unaffected, firefox71 wontfix, firefox72 fixed)

RESOLVED FIXED
mozilla72
Tracking Status
firefox-esr68 --- unaffected
firefox71 --- wontfix
firefox72 --- fixed

People

(Reporter: andi, Assigned: andi)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

The json export for the clang-tidy static-analysis is broken, this broken is because we don't populate the WarningsDatabase with elements.

Regressed by: 1584468
Attachment #9112280 - Attachment description: Bug 1600048 - fix the json exporter for clang-tidy static-analysis. r=bastien → Bug 1600048 - fix the call to `map_file_to_source` that prevented the json export for `clang-tidy` to work. r=bastien
Pushed by bpostelnicu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/51b7b6ca0a42
fix the call to `map_file_to_source` that prevented the json export for `clang-tidy` to work. r=bastien,marco
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
You need to log in before you can comment on or make changes to this bug.