Closed Bug 1600191 Opened 2 years ago Closed 2 years ago

ubuntu1804 - layout/xul/test/test_bug159346.xhtml | scrollbar didn't change curpos by mousedown #1

Categories

(Core :: XUL, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla73
Tracking Status
firefox73 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: masayuki, NeedInfo)

References

Details

Attachments

(2 files)

Filed by: egao [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=278675925&repo=try
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/Qs3e5_KWRZmsf8T8vuv1jA/runs/0/artifacts/public/logs/live_backing.log


suite: mochitest-chrome-1proc
chunk: 2

context:

multiple failures in the same test, all with some sort of mouse error.

[task 2019-11-28T21:13:41.465Z] 21:13:41 INFO - TEST-START | layout/xul/test/test_bug159346.xhtml
[task 2019-11-28T21:13:41.500Z] 21:13:41 INFO - TEST-INFO | started process screentopng
[task 2019-11-28T21:13:41.677Z] 21:13:41 INFO - TEST-INFO | screentopng: exit 0
[task 2019-11-28T21:13:41.677Z] 21:13:41 INFO - TEST-UNEXPECTED-FAIL | layout/xul/test/test_bug159346.xhtml | scrollbar didn't change curpos by mousedown #1
[task 2019-11-28T21:13:41.677Z] 21:13:41 INFO - SimpleTest.ok@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:277:18
[task 2019-11-28T21:13:41.677Z] 21:13:41 INFO - doTest1@chrome://mochitests/content/chrome/layout/xul/test/test_bug159346.xhtml:41:5
[task 2019-11-28T21:13:42.500Z] 21:13:42 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-11-28T21:13:42.501Z] 21:13:42 INFO - TEST-UNEXPECTED-FAIL | layout/xul/test/test_bug159346.xhtml | scrollbar didn't change curpos by auto repeat #1
[task 2019-11-28T21:13:42.501Z] 21:13:42 INFO - SimpleTest.ok@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:277:18
[task 2019-11-28T21:13:42.501Z] 21:13:42 INFO - doTest1/<@chrome://mochitests/content/chrome/layout/xul/test/test_bug159346.xhtml:46:7
[task 2019-11-28T21:13:42.502Z] 21:13:42 INFO - setTimeout handlerSimpleTest_setTimeoutShim@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:686:43
[task 2019-11-28T21:13:42.502Z] 21:13:42 INFO - doTest1@chrome://mochitests/content/chrome/layout/xul/test/test_bug159346.xhtml:45:13
[task 2019-11-28T21:13:43.506Z] 21:13:43 INFO - TEST-PASS | layout/xul/test/test_bug159346.xhtml | scrollbar changed curpos after mouseup #1
[task 2019-11-28T21:13:43.506Z] 21:13:43 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-11-28T21:13:43.506Z] 21:13:43 INFO - TEST-UNEXPECTED-FAIL | layout/xul/test/test_bug159346.xhtml | scrollbar didn't change curpos by mousedown #2
[task 2019-11-28T21:13:43.507Z] 21:13:43 INFO - SimpleTest.ok@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:277:18
[task 2019-11-28T21:13:43.507Z] 21:13:43 INFO - doTest2@chrome://mochitests/content/chrome/layout/xul/test/test_bug159346.xhtml:67:5
[task 2019-11-28T21:13:44.506Z] 21:13:44 INFO - TEST-PASS | layout/xul/test/test_bug159346.xhtml | scrollbar changed curpos by auto repeat when cursor is outside of scrollbar button #2
[task 2019-11-28T21:13:45.511Z] 21:13:45 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-11-28T21:13:45.512Z] 21:13:45 INFO - TEST-UNEXPECTED-FAIL | layout/xul/test/test_bug159346.xhtml | scrollbar didn't change curpos by mousemove after cursor is back on the scrollbar button #2
[task 2019-11-28T21:13:45.512Z] 21:13:45 INFO - SimpleTest.ok@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:277:18
[task 2019-11-28T21:13:45.512Z] 21:13:45 INFO - doTest2/</<@chrome://mochitests/content/chrome/layout/xul/test/test_bug159346.xhtml:81:9
[task 2019-11-28T21:13:45.513Z] 21:13:45 INFO - setTimeout handler
SimpleTest_setTimeoutShim@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:686:43
[task 2019-11-28T21:13:45.513Z] 21:13:45 INFO - doTest2/<@chrome://mochitests/content/chrome/layout/xul/test/test_bug159346.xhtml:80:15
[task 2019-11-28T21:13:45.513Z] 21:13:45 INFO - setTimeout handlerSimpleTest_setTimeoutShim@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:686:43
[task 2019-11-28T21:13:45.513Z] 21:13:45 INFO - doTest2@chrome://mochitests/content/chrome/layout/xul/test/test_bug159346.xhtml:74:13
[task 2019-11-28T21:13:45.513Z] 21:13:45 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-11-28T21:13:45.514Z] 21:13:45 INFO - TEST-UNEXPECTED-FAIL | layout/xul/test/test_bug159346.xhtml | scrollbar didn't change curpos by mousedown #3
[task 2019-11-28T21:13:45.514Z] 21:13:45 INFO - SimpleTest.ok@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:277:18
[task 2019-11-28T21:13:45.514Z] 21:13:45 INFO - doTest3@chrome://mochitests/content/chrome/layout/xul/test/test_bug159346.xhtml:97:5
[task 2019-11-28T21:13:46.515Z] 21:13:46 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-11-28T21:13:46.515Z] 21:13:46 INFO - TEST-UNEXPECTED-FAIL | layout/xul/test/test_bug159346.xhtml | scrollbar didn't change curpos by auto repeat when cursor is outside of scrollbar button #3
[task 2019-11-28T21:13:46.515Z] 21:13:46 INFO - SimpleTest.ok@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:277:18
[task 2019-11-28T21:13:46.516Z] 21:13:46 INFO - doTest3/<@chrome://mochitests/content/chrome/layout/xul/test/test_bug159346.xhtml:103:7
[task 2019-11-28T21:13:46.516Z] 21:13:46 INFO - setTimeout handler
SimpleTest_setTimeoutShim@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:686:43
[task 2019-11-28T21:13:46.516Z] 21:13:46 INFO - doTest3@chrome://mochitests/content/chrome/layout/xul/test/test_bug159346.xhtml:102:13
[task 2019-11-28T21:13:47.516Z] 21:13:47 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-11-28T21:13:47.516Z] 21:13:47 INFO - TEST-UNEXPECTED-FAIL | layout/xul/test/test_bug159346.xhtml | scrollbar didn't change curpos by mousemove after cursor is back on the scrollbar button #3
[task 2019-11-28T21:13:47.516Z] 21:13:47 INFO - SimpleTest.ok@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:277:18
[task 2019-11-28T21:13:47.516Z] 21:13:47 INFO - doTest3/</<@chrome://mochitests/content/chrome/layout/xul/test/test_bug159346.xhtml:109:9
[task 2019-11-28T21:13:47.516Z] 21:13:47 INFO - setTimeout handlerSimpleTest_setTimeoutShim@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:686:43
[task 2019-11-28T21:13:47.516Z] 21:13:47 INFO - doTest3/<@chrome://mochitests/content/chrome/layout/xul/test/test_bug159346.xhtml:108:15
[task 2019-11-28T21:13:47.516Z] 21:13:47 INFO - setTimeout handler
SimpleTest_setTimeoutShim@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:686:43
[task 2019-11-28T21:13:47.516Z] 21:13:47 INFO - doTest3@chrome://mochitests/content/chrome/layout/xul/test/test_bug159346.xhtml:102:13
[task 2019-11-28T21:13:47.516Z] 21:13:47 INFO - GECKO(4504) | MEMORY STAT | vsize 3054MB | residentFast 302MB | heapAllocated 108MB
[task 2019-11-28T21:13:47.532Z] 21:13:47 INFO - TEST-OK | layout/xul/test/test_bug159346.xhtml | took 6058ms

:bgrins - I am observing this test fail consistently when run in the new (work in progress) ubuntu1804 test image. Could you please redirect the ni to someone who may be able to take a look, thanks!

Flags: needinfo?(bgrinstead)

:masayuki - I wonder if this test failure on ubuntu1804 could be related to the other issues we've seen? Perhaps the different desktop environment in ubuntu1804 based on GNOME could be the cause of failure. A bug to investigate if the desktop environment behavior is causing the bug is at 1602387.

Flags: needinfo?(masayuki)

I guess so. The first failure is here:
https://searchfox.org/mozilla-central/rev/23d4bffcad365e68d2d45776017056b76ca9a968/layout/xul/test/test_bug159346.xhtml#41-43
It tries to click down button of scrollbar with really stable code. So, I guess that there are no scrollbar buttons on Ubuntu 1804 environment (maybe hidden?).

Flags: needinfo?(masayuki)

In my VM it does look like there is a scrollbar, but in comparing against ubuntu1604 VM, the scrollbar is narrower (please see screenshot).

I think that might be part of the failure.

:masayuki - I'm not sure how the test is determining where to click - is it done by an offset from the right hand side? If it's a value I can tweak to make the mouse centered where the scroll bar is, I would like to try that.

Flags: needinfo?(masayuki)

Well... It might test clicking on hidden arrow button of scrollbar. If so, I have no idea what causes the failure on ubuntu 18.04... Today, code search of searchfox.org is not available. So, I cannot investigate it more today.

Okay, I got it. The scrollbar button width is 0 (I don't know the reason, though).

Assignee: nobody → masayuki
Status: NEW → ASSIGNED
Flags: needinfo?(masayuki)

test_bug159346.xhtml modifies UA stylesheet to show scrollbar button.
However, on Ubuntu 18.04, its width is 0. Therefore, the following
script fails to test click on the button.

This patch specifies its min-width and min-height to make it
clickable on any platforms.

Attachment #9117655 - Attachment description: Bug 1600191 - Make test_bug159346.xhtml specify `min-height` and `min-width` of scrollbar button to avoid native theme difference r=emilio → Bug 1600191 - Make test_bug159346.xhtml specify `min-height` and `min-width` of scrollbar button to avoid native theme difference
Pushed by masayuki@d-toybox.com:
https://hg.mozilla.org/integration/autoland/rev/99fd4185cc08
Make test_bug159346.xhtml specify `min-height` and `min-width` of scrollbar button to avoid native theme difference r=NeilDeakin
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
You need to log in before you can comment on or make changes to this bug.