Closed Bug 1600252 Opened 10 months ago Closed 10 months ago

privacy.resistFingerprinting breaks https://web.whatsapp.com/

Categories

(Firefox :: Private Browsing, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1446472

People

(Reporter: martin.monperrus, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

When privacy.resistFingerprinting=true, the QR code at https://web.whatsapp.com/ is not displayed.

Attached image Canvas permission panel

The QR code will display if you click on the image icon in the location bar and then "Allow Data Access".

Duplicate of Bug 1446472

This works for me after allowing canvas access, however a page reload is required.

Did you reload the page or do you think it should work directly without reload?

This works for me after allowing canvas access and reload.

My point is that the average reviewer would not think of doing this, she needs some kind of pop up "Warning: resistFingerprinting has blocked something on this page, would you like to activate it? "

(In reply to monperrus from comment #4)

My point is that the average reviewer would not think of doing this, she needs some kind of pop up "Warning: resistFingerprinting has blocked something on this page, would you like to activate it? "

Correct. We disable the visual popup if the website tries to read canvas before user interaction. If it tries to read canvas after user interaction, you get a visual popup.

This isn't ideal, but WhatsApp is hopefully the most prominent website that deals with this. In the future hopefully we can improve this.

Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1446472
You need to log in before you can comment on or make changes to this bug.