Import from Outlook Express: Lost "Mark as read" information

RESOLVED FIXED in Thunderbird 3.0b2

Status

RESOLVED FIXED
16 years ago
10 years ago

People

(Reporter: elihandel, Assigned: philbaseless-firefox)

Tracking

Trunk
Thunderbird 3.0b2
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

When I imported mail folders from Outlook Express, all the e-mail got the little
green diamond indicating "unread", even though I had marked most of them as
"read" in Outlook Express.

Comment 1

16 years ago
This is also true of imports from Eudora 5.1.1, all emails appear "bold" and
unread. 

Comment 2

16 years ago
*** Bug 189117 has been marked as a duplicate of this bug. ***
*** Bug 204890 has been marked as a duplicate of this bug. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

15 years ago
taking - the import code doesn't know if messages are read or not, but I might
be able to figure it out.
Assignee: cavin → bienvenu

Comment 5

15 years ago
Even if you 'read again' messages imported from Outlook Express, they may (=
probably will) later appear as 'unread' because the read flag has been reset. 
If you generally filter messages and look at folders with 'unread' messages in,
this can waste a lot of time!

Comment 6

15 years ago
I poked around but it's hard to figure out the flags from the outlook express
data file format, and make that correspond to the mozilla OE import code.
Product: MailNews → Core

Comment 7

14 years ago
*** Bug 279149 has been marked as a duplicate of this bug. ***
not that messages which are "flagged" in OE also lose that status when they are
imported.

Comment 9

12 years ago
Would be nice to fix this, because the `mark as read' feature is not recursive, people importing large amount of mails from outlook or others, would spend a lot of time to make sure that all their imported folders do not contain unread message.

I suggest:
- always mark messages read on import (possibly an option in the import wizard)
- have a `mark as read' feature which applies to the current folder and subfolder too.

Comment 10

10 years ago
Found this resource that describes the outlook express file format. http://oedbx.aroh.de/ is the general resource with specific information on the read flag(bit 8 of offset 0x01 of the message object) at http://oedbx.aroh.de/doc/OE_Dbx_MessageInfo.html.

Updated

10 years ago
QA Contact: nbaca → import
Product: Core → MailNews Core
(Assignee)

Comment 11

10 years ago
confirmed
flags as well as read, unread flags are not imported.  I know where to get them from OE but will research the import code and try to fix.
(Assignee)

Comment 12

10 years ago
Created attachment 359416 [details] [diff] [review]
adds several tags to imported msgs

adds read tag and others. Need to determine if star, watched, marked etc transfer to proper place.
Attachment #359416 - Flags: review?(bienvenu)

Updated

10 years ago
Assignee: bienvenu → philbaseless-firefox
Status: NEW → ASSIGNED

Updated

10 years ago
Duplicate of this bug: 321399

Comment 14

10 years ago
Comment on attachment 359416 [details] [diff] [review]
adds several tags to imported msgs

this patch has bit-rotted - since it's taken me so long to review this, I'll de-bitrot it and attach a new patch today. One question - I've got OE 6, not OE 5; will I see any effect from this patch?

Comment 15

10 years ago
I do hit a breakpoint in the oe5file code, so I guess the answer is yes.

Unfortunately, import seems to be broken, with or w/o this patch. It claims to successfully import my 8 messages, but the inbox is empty...I wonder if some of the db changes have broken this - I'll debug a little.
(Assignee)

Comment 16

10 years ago
comment 15
I think my message imports always makes a new folder. Not at my machine now, but see if a new folder isn't there called something like oeexpress folders with it's own inbox folder.
(Assignee)

Comment 17

10 years ago
comment 15. OE 5.0 is OE 6.0 (for our purposes). there's an OE 4.0 that has a different registry location but that should be coded in original import code.

Comment 18

10 years ago
Created attachment 360815 [details] [diff] [review]
un-bittrotted patch

this is what I'll checkin - thx for the patch, Phil!
Attachment #359416 - Attachment is obsolete: true
Attachment #360815 - Flags: superreview+
Attachment #360815 - Flags: review+
Attachment #359416 - Flags: review?(bienvenu)

Comment 19

10 years ago
fix checked in, thx, Phil.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0b2
No longer blocks: 475607
You need to log in before you can comment on or make changes to this bug.