Closed Bug 1600571 Opened 2 months ago Closed 2 months ago

Crash in [@ mozilla::dom::ContentChild::RecvCrossProcessRedirect]

Categories

(Core :: Networking, defect)

x86_64
Windows 10
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1598516

People

(Reporter: gsvelto, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug is for crash report bp-6c6be265-5679-4b00-a2b4-2f9610191202.

Top 10 frames of crashing thread:

0 xul.dll mozilla::dom::ContentChild::RecvCrossProcessRedirect dom/ipc/ContentChild.cpp:3686
1 xul.dll mozilla::dom::PContentChild::OnMessageReceived ipc/ipdl/PContentChild.cpp:12255
2 xul.dll void mozilla::ipc::MessageChannel::DispatchMessage ipc/glue/MessageChannel.cpp:2130
3 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1250
4 xul.dll NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:486
5 xul.dll void mozilla::ipc::MessagePump::Run ipc/glue/MessagePump.cpp:88
6 xul.dll void MessageLoop::RunHandler ipc/chromium/src/base/message_loop.cc:308
7 xul.dll MessageLoop::Run ipc/chromium/src/base/message_loop.cc:290
8 xul.dll nsBaseAppShell::Run widget/nsBaseAppShell.cpp:137
9 xul.dll nsAppShell::Run widget/windows/nsAppShell.cpp:406

The raw crash reason is:

MOZ_DIAGNOSTIC_ASSERT(false) (NS_NewChannelInternal failed)

NS_NewChannelInternal → Necko

Component: IPC → Networking
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1598516
You need to log in before you can comment on or make changes to this bug.