Closed Bug 1600860 Opened 7 months ago Closed 7 months ago

[Interventions] The extension needs a way to install an update and restart for users who have opted out of automatic updates

Categories

(Firefox :: Address Bar, task, P1)

task
Points:
2

Tracking

()

RESOLVED FIXED
Firefox 73
Iteration:
73.1 - Dec 2 - Dec 15
Tracking Status
firefox72 --- fixed
firefox73 --- fixed

People

(Reporter: adw, Assigned: adw)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Users can opt out of automatic updates. In that case, when an update is available, we need to let the user download and install it and restart the browser. This case isn't covered in the interventions spec, but it's consistent with the intention to give the user a one-click way to continue on their upgrade path, so I think we should handle it.

Users can opt out of automatic updates. In that case, when an update is available, we need to let the user download and install it and restart the browser. This case isn't covered in the interventions spec, but it's consistent with the intention to give the user a one-click way to continue on their upgrade path, so I think we should handle it.

This patch adds a browser.experiments.urlbar.installBrowserUpdateAndRestart function. At first I made it only install the update, and then the extension called our existing restartBrowser function once that finished. But it didn't work because restartBrowser must be called from a user-input handler, and apparently by awaiting the install function, any code running after the await isn't considered to be in the user-input handler.

I talked with Verdi about this, and he likes it.

Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b959a4f2babf
Add browser.experiments.urlbar.installBrowserUpdateAndRestart. r=mak,mixedpuppy
Regressions: 1601369
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 73

Comment on attachment 9113122 [details]
Bug 1600860 - Add browser.experiments.urlbar.installBrowserUpdateAndRestart.

Beta/Release Uplift Approval Request

  • User impact if declined: We need this in order to run the urlbar interventions experiment (bug 1564506) on 72 as planned.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: Bug 1601369 needed to fix intermittent created by this patch
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is a test-only change. There's no change to shipping code. This patch causes an intermittent failure that's fixed by bug 1601369, so bug 1601369 should also be uplifted.
  • String changes made/needed:
Attachment #9113122 - Flags: approval-mozilla-beta?

Comment on attachment 9113122 [details]
Bug 1600860 - Add browser.experiments.urlbar.installBrowserUpdateAndRestart.

this is test-only

Attachment #9113122 - Flags: approval-mozilla-beta?
Whiteboard: [checkin-needed-beta]
You need to log in before you can comment on or make changes to this bug.