Closed Bug 1601088 Opened 11 months ago Closed 11 months ago

[jsdbg2] DebugAPI::slowPathTraceGeneratorFrame has a bad comment

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla73
Tracking Status
firefox-esr68 --- unaffected
firefox71 --- unaffected
firefox72 --- wontfix
firefox73 --- fixed

People

(Reporter: jimb, Assigned: jimb)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

The comment above the call to TraceCrossCompartmentEdge in DebugAPI::slowPathTraceGeneratorFrame is inaccurate. As Logan notes in D53078:

edgeIsInDebuggerWeakmap verifies the edge from the Debugger.Frame to the AbstractGeneratorObject, but not the other way around. I believe this skips the edgeIsInDebuggerWeakmap entirely because the cross-compartment edge verification that calls edgeIsInDebuggerWeakmap is a callback tracer, so we return above without tracing the edge.

Pushed by jblandy@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1d23d75ef78d
Fix DebugAPI::slowPathTraceGeneratorFrame's justification for calling TraceCrossCompartmentEdge. r=loganfsmyth
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
You need to log in before you can comment on or make changes to this bug.