Closed Bug 1601424 Opened 3 months ago Closed 3 months ago

Firefox 71 unable to write to extension storage

Categories

(Firefox :: Untriaged, defect)

71 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1601365

People

(Reporter: chris24k, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:71.0) Gecko/20100101 Firefox/71.0

Steps to reproduce:

Updated Firefox to version 71 on Fedora Linux.

Actual results:

Extensions are unable to save settings, and keep resetting to defaults upon closing and reopening Firefox. The output of 'df -h' is currently showing 791G of free disk space on /home.

This issue report from Privacy Badger has additional people reporting the same thing, across different Linux distros: https://github.com/EFForg/privacybadger/issues/2474

Expected results:

My settings should have been saved and restored upon opening Firefox.

Fedora 31 here, package firefox-71.0-8.npgo.fc31.x86_64, same issue. LastPass seems to also be bugged out by this in some fashion.

Using openSUSE Leap 15.1 Linux, the addon Privacy Badger crashes immediately after the upgrade from FF 70 to FF 71 which is very likely caused by this problem.

got hit by this one too. Lastpass do not work anymore. Stylus has some strange behaviour. PrivacyBadger fail. Ublock Origin does not work well either.

Seems to have been upgrade from ff70 to 71 on Fedora 31 for me

This is a possible duplicate of bug 1601365

I have the same bug regarding Privacy Badger with Firefox 71 on Debian

Also, when I move the slider from red to green within CookieMaster (https://addons.mozilla.org/en-US/firefox/addon/cookiemaster/), the new position is not saved (If I look into it again, it's still red).

Thanks

and if I add a new whitelist item within Decentreleyes preferences (https://addons.mozilla.org/en-US/firefox/addon/decentraleyes/), it's not saved either

Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1601365
You need to log in before you can comment on or make changes to this bug.