If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

option+click link to download link target is broken

VERIFIED FIXED

Status

Camino Graveyard
General
VERIFIED FIXED
15 years ago
15 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Simon Fraser)

Tracking

({regression})

Details

(Reporter)

Description

15 years ago
found using 2002.07.30.05 nb. option+click link to download link target doesn't
work. (however, option+return a link does work to download a link.)

i thought this used to work, but lemme see if it regressed...
(Reporter)

Comment 1

15 years ago
looks like this broke btwn 7/25 (fine) and 7/29 (broken). will narrow down some
more...
Keywords: regression
QA Contact: winnie → sairuh
(Reporter)

Comment 2

15 years ago
more narrowing: this is fine with the 2002.07.26.05 nb, but broken in the
2002.07.27.05 nb.
Blocks: 147975

Comment 3

15 years ago
->ccarlen, just a guess. Any better candidates?
Assignee: saari → ccarlen
Simon, my guess is that this happened due to some higher-level changes to
downloading rather than uriloader or file stuff.
(Assignee)

Comment 5

15 years ago
I'll take a look
Assignee: ccarlen → sfraser

Comment 6

15 years ago
Not sure if keyboard shortcut changes have something to do with this.  I noticed
that the keyboard shortcuts for Back and Forward were changed since the 07-30
build from cmd-leftarrow/cmd-rightarrow to cmd-[/cmd-].
(Assignee)

Comment 7

15 years ago
It's throwing an exception calling [NSString fileSystemRepresentation] on an
empty string.
Status: NEW → ASSIGNED
(Assignee)

Comment 8

15 years ago
Fixed.
(Assignee)

Comment 9

15 years ago
Really fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

15 years ago
vrfy'd fixed with 2002.08.09.05 chimera bits.
Status: RESOLVED → VERIFIED

Updated

15 years ago
No longer blocks: 147975
You need to log in before you can comment on or make changes to this bug.