Closed Bug 1601868 Opened 3 months ago Closed 3 months ago

Using scrollbar-width:none on root element causes severe scrolling issues with WR picture caching

Categories

(Core :: Graphics: WebRender, defect)

73 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla73
Tracking Status
firefox-esr68 --- unaffected
firefox71 --- unaffected
firefox72 --- unaffected
firefox73 --- verified

People

(Reporter: jastekken, Assigned: gw)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:73.0) Gecko/20100101 Firefox/73.0

Steps to reproduce:

  1. Ensure WR and WR-picture-caching are enabled
  2. Load any page that would overflow the viewport
  3. Enter devtools style-editor and apply :root{ scrollbar-width:none }
  4. Initiate scroll

Actual results:

Viewport does not scroll at all or at least not smoothly.

Expected results:

Viewport should scroll smoothly or instantly.

The issue arises whether smooth scrolling is enabled or not.

I think this problem has likely been triggered by bug 1599656 or perhaps by bug 1599965

I can confirm. I use a userContent.css file with the following line:

*{ scrollbar-width: none }

It hides all scrollbars. Since around Nightly turned 73, it causes severe lag when scrolling unless I disable hardware acceleration in settings.

It happens on two different machines:

  1. Win10 64 bit with Pentium Gold G5400 with integrated graphics.
  2. Win8 32 bit with Nvidia GT 240.

It would be useful to run mozregression on this and see which changeset caused this. I can repro this, it is pretty visible in github for example (I was using this PR).

Status: UNCONFIRMED → NEW
Ever confirmed: true

Thank you Alice! (I couldn't get to it since I didn't have good enough internet when I wrote comment 2).

Glenn, can you take a look? Seems we're incorrectly skipping frames.

Flags: needinfo?(gwatson)
Regressed by: 1599656

Yup, will look into this today.

Assignee: nobody → gwatson
Flags: needinfo?(gwatson)
Pushed by gwatson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bdb6fc50b197
Fix composition skips when scrollbars are disabled. r=nical
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
Flags: qe-verify+

I've managed to reproduce this issue using Firefox 73.0a1 (2019-12-04) on Windows 10x64 by following the STR from comment 0.
This is verified fixed using Firefox 73.0b12 on the following OSes: windows 10x64 and windows 8.1x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.