Closed Bug 1601880 Opened 2 years ago Closed 2 years ago

Add page orientation parameter to snippets preview

Categories

(Firefox :: Messaging System, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 74
Iteration:
74.1 - Jan 6 - Jan 19
Tracking Status
firefox73 --- wontfix
firefox74 --- verified

People

(Reporter: giorgos, Assigned: emcminn)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We want Arabic to display correctly in all Snippet Templates. Prioritize the Simple Snippet and the Simple Snippet Bellow Search bar templates if you tackle each one separately.

Thanks!

Assignee: nobody → emcminn
Blocks: cfr
Iteration: --- → 73.1 - Dec 2 - Dec 15
Priority: -- → P1

Confirmed that this is in fact an issue with the preview feature.
The fix we agreed on was to add a new query parameter similar to how theme works and would flip the page to RTL mode.
This parameter will be used by the snippets preview tool to select the correct layout.

Summary: [Snippets] Arabic are not displayed right-to-left but left-to-right → Add page orientation parameter to snippets preview

The URLSearchParams now has a property "dir", which can be set to "rtl" to preview right-to-left orientation

Iteration: 73.1 - Dec 2 - Dec 15 → 73.2 - Dec 16 - Jan 5

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:emcminn, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(emcminn)

@andreio, would you be able to land this for me? No rush :)

Flags: needinfo?(emcminn)
Iteration: 73.2 - Dec 16 - Jan 5 → 74.1 - Jan 6 - Jan 19
Pushed by aoprea@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8a1dc2b6e104
Added page orientation param to Snippets preview, plus a test for same r=andreio
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 74

Does this need Beta uplift or can it ride Fx74 to release?

Flags: needinfo?(emcminn)

(In reply to Ryan VanderMeulen [:RyanVM] from comment #7)

Does this need Beta uplift or can it ride Fx74 to release?

My impression is that since it only affects the preview feature (not anything user-facing), it's okay for it to ride the trains. :)

Flags: needinfo?(emcminn)

I have verified that this issue is no longer reproducible with the latest Firefox Nightly (74.0a1 Build ID - 20200205055433) installed, on Windows 10 x64, Ubuntu 18.04 x64 and Mac 10.15.2. Now, the below search bar snippet respects the page orientation.
In order to verify this issue I've used the following steps:

  1. Create the browser.newtab.activity-stream.asrouter.whitelistHosts pref with the ["gist.githubusercontent.com"] value in the "about:config" page.
  2. Switch the browser.newtabpage.activity-stream.feeds.asrouterfeed pref's value to false and back to true.
  3. Navigate to about:newtab?endpoint=https://gist.githubusercontent.com/piatra/3029b3336c2df8f64ebb72ca3e027bae/raw/503c53e41a748fd6d1b2be1cd11e45e8c2e49e1b/endpoint.json&dir=rtl .
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.