Closed Bug 160227 Opened 22 years ago Closed 22 years ago

VERSION cookie not set correctly

Categories

(Bugzilla :: Creating/Changing Bugs, defect)

2.17
x86
Linux
defect
Not set
major

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: bbaetz, Assigned: bbaetz)

Details

(Keywords: regression, Whiteboard: [fixed in 2.16.1])

Attachments

(1 file)

The VERSION-$product cookie which post_bug sets is now only a session cookie. I
looked into this, and it appears that apache is printing

               path=/bugzilla/ ; expires=Sun, 30-Jun-2029 00: 00:00 GMT
Set-Cookie: VERSION-Foo=0.999 ; 

Note that the path/expires is _above_ the Set-Cookie line (and on a different
line, too). This is from a network trace; its not a browser thing. This means
that the path/expires stuff isn't used, so it becomes a session cookie, and if
the path isn't / then it won't be used at all (because an existing cookie for
the real path is more specific)

It appears apache is converting the \<nl> in our set-cookie line into the
_opposite_ of a CR, possibly due to the unix line ending?? I'm seeing this on
bmo too, so its not a local thing.

Anyway, the fix is to just use . to concatenate the two strings. I'd love an
explanation, though.
Attached patch v1Splinter Review
This is a regression. Have we decided whether or not to check fixes for these
into the 2.16 branch or not, btw?
Status: NEW → ASSIGNED
Keywords: patch, regression, review
Target Milestone: --- → Bugzilla 2.18
Comment on attachment 93349 [details] [diff] [review]
v1

Yup, regression.  Yup, this fixes it.
Attachment #93349 - Flags: review+
Comment on attachment 93349 [details] [diff] [review]
v1

Just in case the 2.16 branch needs second reviews, here's 2xr=myk.
Attachment #93349 - Flags: review+
This has been checked into the trunk; I've posted to the bugzilla list to
discuss 2.16.1, and I may check it in there after that.

Leaving open for a few days to come to a conclusion.
OK, checked in on teh 2.16 branch too
Status: ASSIGNED → RESOLVED
Closed: 22 years ago
Resolution: --- → FIXED
Whiteboard: fixed in 2.16.1
Whiteboard: fixed in 2.16.1 → [fixed in 2.16.1]
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: