Closed Bug 1602615 Opened 8 months ago Closed 7 months ago

Sometimes drag and drop of URLs causes flicker

Categories

(Core :: Widget: Win32, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla74
Tracking Status
firefox-esr68 --- wontfix
firefox72 --- wontfix
firefox73 --- wontfix
firefox74 --- fixed

People

(Reporter: emk, Assigned: emk)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Steps to reproduce:

  1. Make sure that <localProfileDir\shortcutCache> is empty. I could not find a way to clear this cache from Firefox UI. I deleted icon files directly using File Explorer.
  2. Navigate to any websites that have a favicon <such as http://mozilla.org>.
  3. Drag the lock icon from the URL bar to the desktop.

Actual result:
A shortcut to the website will be created with flickering all Windows.

Expected result:
The shortcut should be created, but flickering should not happen.

This flicker is caused because we broadcast a message to update the shortcut icon after we created a favicon image. (See bug 110894.)

I'm using drag and drop very frequently, so this bug is really annoying.

Assignee: nobody → VYV03354

By making the IStream object free-threaded (or "agile"), IStream::Read will be
called off the main thread. So we can wait until favicon is created.

Depends on D56478

The priority flag is not set for this bug.
:jimm, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(jmathies)
Pushed by VYV03354@nifty.ne.jp:
https://hg.mozilla.org/integration/autoland/rev/ba63fdaa83ba
Add a callback parameter to ObtainCachedIconFile and use it in GetFileContentsInternetShortcut. r=jmathies
https://hg.mozilla.org/integration/autoland/rev/4010545f6193
Add a support for free-threaded IStream to handle Internet shortcuts. r=jmathies
Flags: needinfo?(jmathies)
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74
QA Whiteboard: [qa-74b-p2]
Regressions: 1615293
Regressions: 1636740
You need to log in before you can comment on or make changes to this bug.