Closed Bug 1603321 Opened 3 years ago Closed 3 years ago

MacOS touchbar button "Search or enter address" non-functional when a full-screen video is playing back

Categories

(Core :: Widget: Cocoa, defect, P2)

defect
Points:
3

Tracking

()

VERIFIED FIXED
mozilla74
Iteration:
74.2 - Jan 20 - Feb 09
Tracking Status
firefox74 --- verified

People

(Reporter: ehsan.akhgari, Assigned: bugzilla)

References

(Blocks 1 open bug, Regressed 1 open bug)

Details

Attachments

(1 file)

STR:

  1. Play a video in fullscreen (e.g. from youtube)
  2. Press "Search or enter address".

Nothing happens.

Does this reproduce with full-screen-api.macos-native-full-screen set to true?

Flags: needinfo?(ehsan)
Priority: -- → P2

Yes, it does.

Flags: needinfo?(ehsan)
Flags: needinfo?(htwyford)

What is the desired behaviour here? When a video is playing, the address bar is not visible, nor is it shown when the user moves their mouse to the top of the screen.

We could exit fullscreen first and then focus the address bar, but that seems like it'd be frustrating. The most elegant solution would be to display a media player in the Touch Bar during fullscreen video playback but that would require significant engineering work and I don't think I'd have time for that until Q2 2020 at the earliest. Chrome just displays the video's URL in the Touch Bar while a video is playing, probably as a comprise meant to resolve this exact issue. Maybe we could combine that with a button to enable picture-in-picture?

What do others think? I'll make this as blocked-ux until we make a decision, although we could act on any feasible suggestion from UX or otherwise.

Flags: needinfo?(htwyford)
Keywords: blocked-ux

I'm not going to pretend to be a UX designer even for one second. But I would say the goal that I had for filing this bug was to ensure we didn't display non-functional UI elements in the touchbar to the user -- that seems like a very non-optimal thing to do. I agree with what you said that the ideal thing to display is probably a media player UI similar to Safari, but at the lack of that maybe doing what Chrome does would be an option, or perhaps just hiding the "Search or enter address" button when an element on the page transitions to fullscreen and showing it again when we come back could be another possible option.

To prevent buttons from jumping around in the Touch Bar when the user goes into fullscreen, it's also possible to just disable+grey-out the "Search or enter address" button in fullscreen.

Verdi recommends we replace the "Search or enter address" button with an "Exit Fullscreen" button when we're in fullscreen mode.

Keywords: blocked-ux
Blocks: touchbar

(In reply to Harry Twyford [:harry] from comment #6)

Verdi recommends we replace the "Search or enter address" button with an "Exit Fullscreen" button when we're in fullscreen mode.

"esc" has the same function when in fullscreen mode, FWIW.

Yes, but the big button in the middle of the Touch Bar is meant to highlight primary functionality. Exiting fullscreen is something every user in fullscreen does eventually. While most users probably know that Esc exits fullscreen (especially since we have a prompt that tells them as much...) this gives them a big labelled tap target to do so.

I'm very amenable to doing something other than an "Exit Fullscreen" button, but this approach adds a logically-placed button with relatively little engineering effort.

Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Iteration: --- → 73.2 - Dec 16 - Jan 5
Points: --- → 3
Iteration: 73.2 - Dec 16 - Jan 5 → 74.2 - Jan 20 - Feb 09
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/09bad56df05a
Replace Touch Bar "Search or enter address" button with an "Exit Fullscreen" button while in fullscreen. r=mikedeboer,fluent-reviewers,flod
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74
Regressions: 1611300
Flags: qe-verify+

Tested with Fx 74.0b4 (build ID 20200216164042) on a macOS 10.15.3 and from what it seems this is just partially fix.

After the first exit from the full screen, the message is still the old one "Search or enter addres" but the action is for exiting fullscreen.
Closing this and filled bug 1616290 as a follow-up for the remaining changes that need to be made.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Regressions: 1616290
You need to log in before you can comment on or make changes to this bug.