Closed Bug 1603636 Opened 1 year ago Closed 1 year ago

Find toolbar's "Match Diacritics" Alt+D hotkey conflicts with the address bar

Categories

(Core :: Find Backend, defect)

73 Branch
defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla73
Tracking Status
firefox-esr68 --- unaffected
firefox71 --- unaffected
firefox72 --- unaffected
firefox73 --- verified
firefox74 --- wontfix

People

(Reporter: zlice555, Assigned: alexhenrie24)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:73.0) Gecko/20100101 Firefox/73.0

Steps to reproduce:

in 73 nightly, doing a "ctrl+F" to find on a page now has a "Match Diacritics" hotkey of "alt+D" which breaks the addressbar hotkey of "alt+D"
this should be changed (to "alt+i" which seems to have no hotkey assigned to it?)

ctrl+F
find something (focus stays on findbar)
alt+D

Actual results:

toggles "Match Diacritics"

Expected results:

go to URL bar

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:73.0) Gecko/20100101 Firefox/73.0
20191212215040

Alt+D to focus the address bar has been around for ages. It should still work even when the find toolbar is open.

Status: UNCONFIRMED → NEW
Component: Untriaged → Find Backend
Ever confirmed: true
OS: Unspecified → All
Product: Firefox → Core
Regressed by: 202251
Hardware: Unspecified → All
Summary: diacritics findbar hotkey breaks address bar hotkey → Find toolbar's "Match Diacritics" Alt+D hotkey conflicts with the address bar

Interesting. I was actually unaware of Alt+D because I always use Ctrl+L instead.

Assignee: nobody → alexhenrie24
Pushed by ccoroiu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5aa3fbff84f5
Change "Match Diacritics" shortcut to Alt+I. r=fluent-reviewers,mikedeboer,flod
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73

thanks all

See Also: → 1608096

Reproduced the issue using Firefox 73.0a1 (20191212215040) on Windows 10x64.
The issue is verified fixed with 73.0b8 (20200122012721) on Windows 10x64, macOS 10.15 and Ubuntu 18.04. Pressing ALT+D after CTR+F focuses the address bar (Windows and Ubuntu) and "Match Diacritics" is selected with ALT+I as expected.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

This is not fixed at least for Chinese language pack for Firefox 74.

The Match Diacritics under Simplified Chinese locale is still using "d" as accelerator. (搜索变音文字(_D))

Flags: needinfo?(alexhenrie24)

I made a request at https://pontoon.mozilla.org/zh-CN/firefox/toolkit/toolkit/main-window/findbar.ftl/?string=206128 but I don't have any control over whether it will be accepted or when.

Flags: needinfo?(alexhenrie24) → needinfo?(yfdyh000)

I see this change has been approved.

Flags: needinfo?(yfdyh000)
You need to log in before you can comment on or make changes to this bug.