Closed Bug 1603869 Opened 2 years ago Closed 2 years ago

Intermittent dom/url/tests/browser_download_after_revoke.js | A promise chain failed to handle a rejection: [Exception... "(null)" nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)" location: "<unknown>" data: no] - stack: (No stack available.)

Categories

(Core :: DOM: Networking, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla73
Tracking Status
firefox73 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: valentin)

References

(Regression)

Details

(Keywords: intermittent-failure, Whiteboard: [necko-triaged])

Attachments

(1 file)

Filed by: apavel [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=281124895&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/KlMup7xnQ1ygEFLhXWs_aQ/runs/0/artifacts/public/logs/live_backing.log


[task 2019-12-13T22:00:27.096Z] 22:00:27 INFO - TEST-START | dom/url/tests/browser_download_after_revoke.js
[task 2019-12-13T22:00:27.097Z] 22:00:27 INFO - GECKO(11613) | Chrome file doesn't exist: /builds/worker/workspace/build/tests/mochitest/browser/dom/url/tests/head.js
[task 2019-12-13T22:00:27.192Z] 22:00:27 INFO - GECKO(11613) | ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to /tmp/tmpTntBYj.mozrunner/runtests_leaks_tab_pid11775.log
[task 2019-12-13T22:00:27.208Z] 22:00:27 INFO - GECKO(11613) | [Child 11775, Main Thread] WARNING: No CID found when attempting to map contract ID: file /builds/worker/workspace/build/src/xpcom/components/nsComponentManager.cpp, line 727
[task 2019-12-13T22:00:27.336Z] 22:00:27 INFO - GECKO(11613) | Couldn't convert chrome URL: chrome://branding/locale/brand.properties
[task 2019-12-13T22:00:27.518Z] 22:00:27 INFO - GECKO(11613) | [Child 11775, Main Thread] WARNING: could not set real-time limit at process startup: file /builds/worker/workspace/build/src/dom/ipc/ContentChild.cpp, line 1819
[task 2019-12-13T22:00:27.518Z] 22:00:27 INFO - GECKO(11613) | [Child 11775: Main Thread]: I/DocShellAndDOMWindowLeak ++DOCSHELL 0x7fe5bb8d2000 == 1 [pid = 11775] [id = {8f456574-ec8b-4823-b094-70e38914152b}]
[task 2019-12-13T22:00:27.580Z] 22:00:27 INFO - GECKO(11613) | [Child 11775: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 1 (0x7fe5bc7d8f20) [pid = 11775] [serial = 1] [outer = (nil)]

[task 2019-12-13T22:00:43.911Z] 22:00:43 INFO - GECKO(11613) | [Child 11775: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 0 (0x7fe5bb478400) [pid = 11775] [serial = 3] [outer = (nil)] [url = about:blank]
[task 2019-12-13T22:01:57.221Z] 22:01:57 INFO - TEST-INFO | started process screentopng
[task 2019-12-13T22:01:58.121Z] 22:01:58 INFO - TEST-INFO | screentopng: exit 0
[task 2019-12-13T22:01:58.123Z] 22:01:58 INFO - Buffered messages logged at 22:00:27
[task 2019-12-13T22:01:58.123Z] 22:01:58 INFO - Loading download page...
[task 2019-12-13T22:01:58.124Z] 22:01:58 INFO - Page loaded.
[task 2019-12-13T22:01:58.124Z] 22:01:58 INFO - Creating BlobURL and clicking on a HTMLAnchorElement...
[task 2019-12-13T22:01:58.125Z] 22:01:58 INFO - Buffered messages logged at 22:00:28
[task 2019-12-13T22:01:58.125Z] 22:01:58 INFO - Console message: [JavaScript Error: "TypeError: browsingContext.currentWindowGlobal is null" {file: "resource://specialpowers/SpecialPowersParent.jsm" line: 1045}]
[task 2019-12-13T22:01:58.126Z] 22:01:58 INFO - Console message: [JavaScript Error: "NS_ERROR_UNEXPECTED"]
[task 2019-12-13T22:01:58.126Z] 22:01:58 INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://example.com/browser/dom/url/tests/empty.html" line: 0}]
[task 2019-12-13T22:01:58.127Z] 22:01:58 INFO - Buffered messages finished
[task 2019-12-13T22:01:58.127Z] 22:01:58 INFO - TEST-UNEXPECTED-FAIL | dom/url/tests/browser_download_after_revoke.js | Test timed out -
[task 2019-12-13T22:01:58.127Z] 22:01:58 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-12-13T22:01:58.127Z] 22:01:58 INFO - TEST-UNEXPECTED-FAIL | dom/url/tests/browser_download_after_revoke.js | A promise chain failed to handle a rejection: [Exception... "(null)" nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)" location: "<unknown>" data: no] - stack: (No stack available.)
[task 2019-12-13T22:01:58.128Z] 22:01:58 INFO - Rejection date: Fri Dec 13 2019 22:00:28 GMT+0000 (Coordinated Universal Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 265
[task 2019-12-13T22:01:58.128Z] 22:01:58 INFO - Stack trace:
[task 2019-12-13T22:01:58.128Z] 22:01:58 INFO - resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:265
[task 2019-12-13T22:01:58.129Z] 22:01:58 INFO - chrome://mochikit/content/browser-test.js:nextTest:624
[task 2019-12-13T22:01:58.129Z] 22:01:58 INFO - chrome://mochikit/content/browser-test.js:timeoutFn:1183
[task 2019-12-13T22:01:58.129Z] 22:01:58 INFO - setTimeout handler*chrome://mochikit/content/browser-test.js:Tester_execTest:1130
[task 2019-12-13T22:01:58.129Z] 22:01:58 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:925
[task 2019-12-13T22:01:58.129Z] 22:01:58 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:808
[task 2019-12-13T22:01:58.130Z] 22:01:58 INFO - GECKO(11613) | MEMORY STAT vsizeMaxContiguous not supported in this build configuration.
[task 2019-12-13T22:01:58.131Z] 22:01:58 INFO - GECKO(11613) | MEMORY STAT | vsize 2946MB | residentFast 326MB | heapAllocated 101MB
[task 2019-12-13T22:01:58.132Z] 22:01:58 INFO - TEST-OK | dom/url/tests/browser_download_after_revoke.js | took 90155ms
[task 2019-12-13T22:01:58.132Z] 22:01:58 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-12-13T22:01:58.133Z] 22:01:58 INFO - TEST-UNEXPECTED-FAIL | dom/url/tests/browser_download_after_revoke.js | Found a tab after previous test timed out: http://example.com/browser/dom/url/tests/empty.html -
[task 2019-12-13T22:01:58.133Z] 22:01:58 INFO - GECKO(11613) | [Child 11828: Main Thread]: I/DocShellAndDOMWindowLeak ++DOCSHELL 0x7f11abccd000 == 1 [pid = 11828] [id = {2ff94988-b10e-4d91-9a58-9de4908a403b}]
[task 2019-12-13T22:01:58.134Z] 22:01:58 INFO - checking window state
[task 2019-12-13T22:01:58.134Z] 22:01:58 INFO - GECKO(11613) | [Child 11828: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 1 (0x7f11abb04f20) [pid = 11828] [serial = 1] [outer = (nil)]
[task 2019-12-13T22:01:58.138Z] 22:01:58 INFO - GECKO(11613) | [Child 11828, Main Thread] WARNING: NS_ENSURE_TRUE(mPresShell) failed: file /builds/worker/workspace/build/src/layout/base/nsPresContext.cpp, line 848
[task 2019-12-13T22:01:58.138Z] 22:01:58 INFO - GECKO(11613) | [Child 11828: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 2 (0x7f11abe34800) [pid = 11828] [serial = 2] [outer = 0x7f11abb04f20]
[task 2019-12-13T22:01:58.139Z] 22:01:58 INFO - GECKO(11613) | [Parent 11613, Main Thread] WARNING: NS_ENSURE_TRUE(GetWrapper()) failed: file /builds/worker/workspace/build/src/dom/ipc/JSWindowActor.cpp, line 58
[task 2019-12-13T22:01:58.139Z] 22:01:58 INFO - GECKO(11613) | [Parent 11613, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file /builds/worker/workspace/build/src/dom/base/nsFrameLoader.cpp, line 666
[task 2019-12-13T22:01:58.140Z] 22:01:58 INFO - GECKO(11613) | [Parent 11613: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 11 (0x7f00caf81c00) [pid = 11613] [serial = 13] [outer = 0x7f00dd3976a0]
[task 2019-12-13T22:01:58.142Z] 22:01:58 INFO - GECKO(11613) | [Parent 11613: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 12 (0x7f00cb0c1400) [pid = 11613] [serial = 14] [outer = 0x7f00dd3976a0]
[task 2019-12-13T22:01:58.142Z] 22:01:58 INFO - GECKO(11613) | [Child 11799: Main Thread]: I/DocShellAndDOMWindowLeak --DOCSHELL 0x7f4535dd2800 == 0 [pid = 11799] [id = {8f456574-ec8b-4823-b094-70e38914152b}] [url = http://example.com/browser/dom/url/tests/empty.html]
[task 2019-12-13T22:01:58.142Z] 22:01:58 INFO - GECKO(11613) | [Child 11746: Main Thread]: I/DocShellAndDOMWindowLeak --DOCSHELL 0x7fac05bcb000 == 0 [pid = 11746] [id = {84643f10-6eb3-43cd-b635-e8e3415ca829}] [url = about:blank]
[task 2019-12-13T22:01:58.143Z] 22:01:58 INFO - GECKO(11613) | [Child 11799: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 1 (0x7f4536dc9f20) [pid = 11799] [serial = 1] [outer = (nil)] [url = http://example.com/browser/dom/url/tests/empty.html]
[task 2019-12-13T22:01:58.143Z] 22:01:58 INFO - GECKO(11613) | [Child 11799: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 0 (0x7f4535979c00) [pid = 11799] [serial = 3] [outer = (nil)] [url = http://example.com/browser/dom/url/tests/empty.html]
[task 2019-12-13T22:01:58.144Z] 22:01:58 INFO - GECKO(11613) | [Child 11799, Main Thread] WARNING: Extra shutdown CC: 'i < NORMAL_SHUTDOWN_COLLECTIONS', file /builds/worker/workspace/build/src/xpcom/base/nsCycleCollector.cpp, line 3361
[task 2019-12-13T22:01:58.144Z] 22:01:58 INFO - GECKO(11613) | nsStringStats

Regressed by: 1596918

(In reply to Treeherder Bug Filer from comment #0)

[task 2019-12-13T22:01:58.125Z] 22:01:58 INFO - Console message: [JavaScript Error: "TypeError: browsingContext.currentWindowGlobal is null" {file: "resource://specialpowers/SpecialPowersParent.jsm" line: 1045}]

Kris, this seems to be a regression. Does it require a fix in SpecialPowers, or is the test at fault?

Flags: needinfo?(kmaglione+bmo)

(In reply to Valentin Gosu [:valentin] (he/him) from comment #1)

(In reply to Treeherder Bug Filer from comment #0)

[task 2019-12-13T22:01:58.125Z] 22:01:58 INFO - Console message: [JavaScript Error: "TypeError: browsingContext.currentWindowGlobal is null" {file: "resource://specialpowers/SpecialPowersParent.jsm" line: 1045}]

Kris, this seems to be a regression. Does it require a fix in SpecialPowers, or is the test at fault?

Probably mostly the latter. The problem is that browserLoaded sometimes resolves for an initial or intermediate "about:blank" page if you don't pass it a URL to wait for, which means that onLoad will sometimes wind up being called when the browser is in an inconsistent state.

Flags: needinfo?(kmaglione+bmo)

Thanks for the info. I did not know that.
Let's see if this fixes it.

Assignee: nobody → valentin.gosu
Priority: P5 → P2
Whiteboard: [necko-triaged]
Pushed by valentin.gosu@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/55439809207c
Pass URL to BrowserTestUtils.browserLoaded in browser_download_after_revoke.js r=kmag
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
You need to log in before you can comment on or make changes to this bug.