Playing games locks Browser and System up

RESOLVED WORKSFORME

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED WORKSFORME
16 years ago
8 years ago

People

(Reporter: Jason Smith, Assigned: Joe Chou)

Tracking

({hang})

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1b) Gecko/20020731
BuildID:    2002071914

Then trying to play games on Pogo or to a lesser extent yahoo results in 
the entire browser and system to lock up. IE has absolutely no problems with
these games...

This has been duplicated on Windows XP as well... 

CTRL-ALT-DEL doesn't work when this happens.

As a result 5 potential users I am aquainted with have uninstalled it stating
that the browser is "broken".

Reproducible: Sometimes
Steps to Reproduce:
1.www.pogo.com
2.play one of the online games
3.

Comment 1

16 years ago
I noticed this with some shockwave flash games for a while.
Can you try if it helps to uncheck "enable pipelining" under
preferences/advanced/HTTP networking ?
(Reporter)

Comment 2

16 years ago
RKAa

This option has never been checked...

Comment 3

16 years ago
There is a "lot" of bugs related to pogo.com

Is this related (or even a duplicate) of bug 150498 ("Java Game either
Non-Portable or we have a bad implementation") ?

Comment 4

16 years ago
Yes, pogo.com has a lot of bugs about the games... but they are all different
enough that I coudn't mark them dups (Bug 150498, for example, doesn't hang). 
Perhaps we need a tracking bug or something for this?  I suspect that this is a
Java issue.

Jason Smith:  which version of the flash plugin and JRE do you have installed?
Keywords: hang
(Reporter)

Comment 5

16 years ago
I have experienced the bugs on both 1.31 and 1.41. As well under XP, Windows
98SE and ME.

Shockwave Flash 6.0 r29
Shockwave Flash for Director 8.5
Quicktime 5.0.2
Right now I have JRE 1.4.1 installed but have had the problems under 1.3.1 as well.

I have also noted under the recent builds an inablility to run the Java based
command line on my Linux router (remote administer). I get the following error
under the java console:
avax.net.ssl.SSLException: SSL V2.0 servers are not supported.

	at com.sun.net.ssl.internal.ssl.InputRecord.b(Unknown Source)

	at com.sun.net.ssl.internal.ssl.InputRecord.read(Unknown Source)

	at com.sun.net.ssl.internal.ssl.SSLSocketImpl.a(Unknown Source)

	at com.sun.net.ssl.internal.ssl.SSLSocketImpl.j(Unknown Source)

	at com.sun.net.ssl.internal.ssl.SSLSocketImpl.startHandshake(Unknown Source)

	at sun.net.www.protocol.https.HttpsClient.afterConnect(Unknown Source)

	at
sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.setNewClient(Unknown
Source)

	at
sun.net.www.protocol.https.PluginDelegateHttpsURLConnection.superConnect(Unknown
Source)

	at
sun.net.www.protocol.https.PluginDelegateHttpsURLConnection.access$000(Unknown
Source)

	at sun.net.www.protocol.https.PluginDelegateHttpsURLConnection$1.run(Unknown
Source)

	at java.security.AccessController.doPrivileged(Native Method)

	at sun.net.www.protocol.https.PluginDelegateHttpsURLConnection.connect(Unknown
Source)

	at
sun.net.www.protocol.https.PluginDelegateHttpsURLConnection.getInputStream(Unknown
Source)

	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(Unknown Source)

	at sun.plugin.net.protocol.http.HttpUtils.followRedirects(Unknown Source)

	at sun.plugin.cache.CachedJarLoader.isUpToDate(Unknown Source)

	at sun.plugin.cache.CachedJarLoader.loadFromCache(Unknown Source)

	at sun.plugin.cache.CachedJarLoader.load(Unknown Source)

	at sun.plugin.cache.JarCache.get(Unknown Source)

	at sun.plugin.net.protocol.jar.CachedJarURLConnection.connect(Unknown Source)

	at sun.plugin.net.protocol.jar.CachedJarURLConnection.getJarFile(Unknown Source)

	at sun.misc.URLClassPath$JarLoader.getJarFile(Unknown Source)

	at sun.misc.URLClassPath$JarLoader.<init>(Unknown Source)

	at sun.misc.URLClassPath$3.run(Unknown Source)

	at java.security.AccessController.doPrivileged(Native Method)

	at sun.misc.URLClassPath.getLoader(Unknown Source)

	at sun.misc.URLClassPath.getLoader(Unknown Source)

	at sun.misc.URLClassPath.getResource(Unknown Source)

	at java.net.URLClassLoader$1.run(Unknown Source)

	at java.security.AccessController.doPrivileged(Native Method)

	at java.net.URLClassLoader.findClass(Unknown Source)

	at sun.applet.AppletClassLoader.findClass(Unknown Source)

	at sun.plugin.security.PluginClassLoader.findClass(Unknown Source)

	at java.lang.ClassLoader.loadClass(Unknown Source)

	at sun.applet.AppletClassLoader.loadClass(Unknown Source)

	at java.lang.ClassLoader.loadClass(Unknown Source)

	at sun.applet.AppletClassLoader.loadCode(Unknown Source)

	at sun.applet.AppletPanel.createApplet(Unknown Source)

	at sun.plugin.AppletViewer.createApplet(Unknown Source)

	at sun.applet.AppletPanel.runLoader(Unknown Source)

	at sun.applet.AppletPanel.run(Unknown Source)

	at java.lang.Thread.run(Unknown Source)

javax.net.ssl.SSLException: SSL V2.0 servers are not supported.

	at com.sun.net.ssl.internal.ssl.InputRecord.b(Unknown Source)

	at com.sun.net.ssl.internal.ssl.InputRecord.read(Unknown Source)

	at com.sun.net.ssl.internal.ssl.SSLSocketImpl.a(Unknown Source)

	at com.sun.net.ssl.internal.ssl.SSLSocketImpl.j(Unknown Source)

	at com.sun.net.ssl.internal.ssl.SSLSocketImpl.startHandshake(Unknown Source)

	at sun.net.www.protocol.https.HttpsClient.afterConnect(Unknown Source)

	at
sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.setNewClient(Unknown
Source)

	at
sun.net.www.protocol.https.PluginDelegateHttpsURLConnection.superConnect(Unknown
Source)

	at
sun.net.www.protocol.https.PluginDelegateHttpsURLConnection.access$000(Unknown
Source)

	at sun.net.www.protocol.https.PluginDelegateHttpsURLConnection$1.run(Unknown
Source)

	at java.security.AccessController.doPrivileged(Native Method)

	at sun.net.www.protocol.https.PluginDelegateHttpsURLConnection.connect(Unknown
Source)

	at
sun.net.www.protocol.https.PluginDelegateHttpsURLConnection.getInputStream(Unknown
Source)

	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(Unknown Source)

	at sun.plugin.cache.CachedJarLoader.decompress(Unknown Source)

	at sun.plugin.cache.CachedJarLoader.access$500(Unknown Source)

	at sun.plugin.cache.CachedJarLoader$5.run(Unknown Source)

	at java.security.AccessController.doPrivileged(Native Method)

	at sun.plugin.cache.Cache.privileged(Unknown Source)

	at sun.plugin.cache.CachedJarLoader.download(Unknown Source)

	at sun.plugin.cache.CachedJarLoader.load(Unknown Source)

	at sun.plugin.cache.JarCache.get(Unknown Source)

	at sun.plugin.net.protocol.jar.CachedJarURLConnection.connect(Unknown Source)

	at sun.plugin.net.protocol.jar.CachedJarURLConnection.getJarFile(Unknown Source)

	at sun.misc.URLClassPath$JarLoader.getJarFile(Unknown Source)

	at sun.misc.URLClassPath$JarLoader.<init>(Unknown Source)

	at sun.misc.URLClassPath$3.run(Unknown Source)

	at java.security.AccessController.doPrivileged(Native Method)

	at sun.misc.URLClassPath.getLoader(Unknown Source)

	at sun.misc.URLClassPath.getLoader(Unknown Source)

	at sun.misc.URLClassPath.getResource(Unknown Source)

	at java.net.URLClassLoader$1.run(Unknown Source)

	at java.security.AccessController.doPrivileged(Native Method)

	at java.net.URLClassLoader.findClass(Unknown Source)

	at sun.applet.AppletClassLoader.findClass(Unknown Source)

	at sun.plugin.security.PluginClassLoader.findClass(Unknown Source)

	at java.lang.ClassLoader.loadClass(Unknown Source)

	at sun.applet.AppletClassLoader.loadClass(Unknown Source)

	at java.lang.ClassLoader.loadClass(Unknown Source)

	at sun.applet.AppletClassLoader.loadCode(Unknown Source)

	at sun.applet.AppletPanel.createApplet(Unknown Source)

	at sun.plugin.AppletViewer.createApplet(Unknown Source)

	at sun.applet.AppletPanel.runLoader(Unknown Source)

	at sun.applet.AppletPanel.run(Unknown Source)

	at java.lang.Thread.run(Unknown Source)

load: class mindbright.application.MindTerm.class not found.

java.lang.ClassNotFoundException: mindbright.application.MindTerm.class

	at sun.applet.AppletClassLoader.findClass(Unknown Source)

	at sun.plugin.security.PluginClassLoader.findClass(Unknown Source)

	at java.lang.ClassLoader.loadClass(Unknown Source)

	at sun.applet.AppletClassLoader.loadClass(Unknown Source)

	at java.lang.ClassLoader.loadClass(Unknown Source)

	at sun.applet.AppletClassLoader.loadCode(Unknown Source)

	at sun.applet.AppletPanel.createApplet(Unknown Source)

	at sun.plugin.AppletViewer.createApplet(Unknown Source)

	at sun.applet.AppletPanel.runLoader(Unknown Source)

	at sun.applet.AppletPanel.run(Unknown Source)

	at java.lang.Thread.run(Unknown Source)

Caused by: javax.net.ssl.SSLException: SSL V2.0 servers are not supported.

	at com.sun.net.ssl.internal.ssl.InputRecord.b(Unknown Source)

	at com.sun.net.ssl.internal.ssl.InputRecord.read(Unknown Source)

	at com.sun.net.ssl.internal.ssl.SSLSocketImpl.a(Unknown Source)

	at com.sun.net.ssl.internal.ssl.SSLSocketImpl.j(Unknown Source)

	at com.sun.net.ssl.internal.ssl.SSLSocketImpl.startHandshake(Unknown Source)

	at sun.net.www.protocol.https.HttpsClient.afterConnect(Unknown Source)

	at
sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.setNewClient(Unknown
Source)

	at
sun.net.www.protocol.https.PluginDelegateHttpsURLConnection.superConnect(Unknown
Source)

	at
sun.net.www.protocol.https.PluginDelegateHttpsURLConnection.access$000(Unknown
Source)

	at sun.net.www.protocol.https.PluginDelegateHttpsURLConnection$1.run(Unknown
Source)

	at java.security.AccessController.doPrivileged(Native Method)

	at sun.net.www.protocol.https.PluginDelegateHttpsURLConnection.connect(Unknown
Source)

	at
sun.net.www.protocol.https.PluginDelegateHttpsURLConnection.getInputStream(Unknown
Source)

	at java.net.HttpURLConnection.getResponseCode(Unknown Source)

	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(Unknown
Source)

	at sun.applet.AppletClassLoader.getBytes(Unknown Source)

	at sun.applet.AppletClassLoader.access$100(Unknown Source)

	at sun.applet.AppletClassLoader$1.run(Unknown Source)

	at java.security.AccessController.doPrivileged(Native Method)

	... 11 more

I am not sure they are relevant to this issue and was considering filing a bug
report on it... But will download a nightly build before doing so... (I am using
2002092308 right now).

Comment 6

16 years ago
Jason, there's not a lot to go on with this bug report.  Would you be willing to
mark this a duplicate of bug 150498, and add additional comments to that bug
about your problem?  It may me MS-specific java code, a bug with Sun Java, or a
bug in mozilla, but isolating the problem may be very difficult.
oji
Assignee: Matti → joe.chou
Component: Browser-General → OJI
QA Contact: asa → petersen
(Reporter)

Comment 8

16 years ago
Benjamin... 

I am sorry I can not give more info... I would love to be able to get the Java
console output to post to ya but unfortunately when it occurs the machine locks
up and reset is my only option (under all O/S's I previously listed). How does
one determine that the apps are written in MS specific Java??? Would it then be
prudent to contact the game provider for some resolution???

I looked at the bug you listed and I noticed the severity of its reaction is
considerably less than what I have seen occuring... As previously stated I have
numerous people interested in this browser (or derivatives thereof) but they
will not touch with 10 ft pole as they cannot use it as they would IE.

Updated

16 years ago
Blocks: 194663

Comment 9

14 years ago
worksforme with 2004041608 mozilla 1.7 branch build on windows XP with JRE 1.5 beta.

Comment 10

13 years ago
This wfm using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050409 Firefox/1.0+
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.