Closed Bug 160402 Opened 21 years ago Closed 21 years ago

profile manager too aggressive in maintaining identities over multiple instances of Mozilla

Categories

(SeaMonkey :: Startup & Profiles, defect)

x86
Linux
defect
Not set
minor

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 135137

People

(Reporter: levente, Assigned: bugs)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020717
BuildID:    2002071722

Misfeature, not a bug, in my opinion.  Manifests itself exactly under the same
circumstances as Netscape 4.7's "I have detected a lock file...."  However, far
more aggressive, in that it absolutely refuses to share the same profile between
2 instances.  In order to force the 2nd to work, I can either close the first,
or blitz the profile and create a new one.  (I use only one, the "default
profile", I have to keep recreating it often.)  When I do this, the new instance
works fine.  

Reproducible: Always
Steps to Reproduce:
1. Log into your account, load Mozilla.
2. Load *another* instance of Mozilla.

Actual Results:  Second Mozilla detects that first is running, and using the
"default profile".  I am forced to blitz the profile, and create a new one, and
then both Mozillae work.

Expected Results:  two Mozillae should coexist peacefully.

Not sure how the first Mozilla handles it.  Sometimes it continues to work fine,
other times it dies - it appears to be working fine, except any and all URLs I
try end up invalid.  Not sure if the two bugs are related - the first is
guaranteed reproducable, the second is very flaky.
dupe of "Profile data cannot be shared by multiple running instances."

Mozilla prevents you from running two instances of the same profile BECAUSE of
the bad things that happen.

a more practical solution to your problem is bug 122698

*** This bug has been marked as a duplicate of 135137 ***
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Verified as a dupe of bug 135137
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.