Closed Bug 1604135 Opened 3 years ago Closed 2 years ago

Crash in [@ rx::TextureStorage11::setData]

Categories

(Core :: Graphics: WebRender, defect, P3)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: gsvelto, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-1f764b4d-c735-4347-b991-4210d0191214.

Top 10 frames of crashing thread:

0 libglesv2.dll rx::TextureStorage11::setData gfx/angle/checkout/src/libANGLE/renderer/d3d/d3d11/TextureStorage11.cpp:805
1 libglesv2.dll rx::TextureD3D::subImage gfx/angle/checkout/src/libANGLE/renderer/d3d/TextureD3D.cpp:305
2 libglesv2.dll rx::TextureD3D_2DArray::setSubImage gfx/angle/checkout/src/libANGLE/renderer/d3d/TextureD3D.cpp:3128
3 libglesv2.dll gl::Texture::setSubImage gfx/angle/checkout/src/libANGLE/Texture.cpp:1055
4 libglesv2.dll gl::Context::texSubImage3D gfx/angle/checkout/src/libANGLE/Context.cpp:4194
5 libglesv2.dll gl::TexSubImage3D gfx/angle/checkout/src/libGLESv2/entry_points_gles_3_0_autogen.cpp:1569
6 xul.dll gleam::gl::{{impl}}::tex_sub_image_3d third_party/rust/gleam/src/gles_fns.rs:802
7 xul.dll webrender::device::gl::UploadTarget::update_impl gfx/wr/webrender/src/device/gl.rs:3688
8 xul.dll webrender::device::gl::TextureUploader<u8>::upload<u8> gfx/wr/webrender/src/device/gl.rs:3643
9 xul.dll webrender::renderer::Renderer::update_texture_cache gfx/wr/webrender/src/renderer.rs:3394

This is a NULL pointer dereference that seems to have started in buildid 20191209095039.

I am assuming this is because of Direct Comp, which we have since turned off

Flags: needinfo?(gwatson)
Priority: -- → P3

The backtrace above doesn't look like it's related to DirectComposition. I think we've landed some other texture upload work recently, maybe related to that?

Flags: needinfo?(gwatson) → needinfo?(jbonisteel)

Jamie, not sure if this could be related to your work recently?

No longer blocks: WR-Win-Compositing
Flags: needinfo?(jbonisteel) → needinfo?(jnicol)

No, that patch shouldn't have changed anything on windows, although that was my first thought when I saw this. But the build-IDs don't match up - reports started in builds a couple days before my change landed, and continued after it got backed out.

I am completely stumped about what the cause could be, though.

Flags: needinfo?(jnicol)

Closing because no crashes reported for 12 weeks.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression
You need to log in before you can comment on or make changes to this bug.