Last Comment Bug 160500 - <noframes> content visible when <frameset> is loaded
: <noframes> content visible when <frameset> is loaded
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout: HTML Frames (show other bugs)
: Trunk
: x86 Windows NT
: -- normal (vote)
: ---
Assigned To: John Keiser (jkeiser)
: Amarendra Hanumanula
: Jet Villegas (:jet)
Mentors:
http://selfhtml.teamone.de/html/frame...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-01 05:53 PDT by Günni
Modified: 2002-12-09 14:05 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Testcase (322 bytes, text/html)
2002-08-01 07:53 PDT, Bill Mason
no flags Details
testcase 2 (681 bytes, text/html)
2002-08-20 14:34 PDT, Bob Clary [:bc:]
no flags Details

Description Günni 2002-08-01 05:53:12 PDT
When using the <noframes> Tag in a <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01
Transitional//EN"> page the browser shows the text within the <noframes> area.
Comment 1 Günni 2002-08-01 05:54:35 PDT
German example can be viewed at
http://selfhtml.teamone.de/html/frames/anzeige/frames2.htm
Comment 2 Adrian Ulrich 2002-08-01 06:20:01 PDT
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"> isn't the
correct doctype for a Frameset


http://selfhtml.teamone.de/html/frames/anzeige/frames2.htm WFM with 20020731 on
linux (Btw: it has another doctype!)

.. Could you provide a testcase for this?
Comment 3 Günni 2002-08-01 06:30:00 PDT
The frameset is defined as "-//W3C//DTD HTML 4.01 Frameset//EN" and the browser
does not show the text within <noframes> which is correct.
But if a browser does not support frames the <noframes> Tag can be used for
those browsers on _every page_ to enable navigation for them (e.g.).
Therefore the <noframes> Tag should not be ignored in other doctypes, such as
"-//W3C//DTD HTML 4.01 Transitional//EN".
Comment 4 Bill Mason 2002-08-01 07:53:58 PDT
Created attachment 93574 [details]
Testcase
Comment 5 Bill Mason 2002-08-01 08:03:20 PDT
In reference to comment 2, the 4.01 spec specifically says that NOFRAMES can be
used in a non-frameset DTD:
"NOFRAMES may be used, for example, in a document that is the source of a frame
and that uses the transitional DTD. This allows authors to explain the
document's purpose in cases when it is viewed out of the frameset or with a user
agent that doesn't support frames."
<http://www.w3.org/TR/html4/present/frames.html#edef-NOFRAMES"

I attached a minimal testcase.

However, this whole bug dups bug 47658 in any event.

*** This bug has been marked as a duplicate of 47658 ***
Comment 6 Bill Mason 2002-08-01 08:04:58 PDT
My mistake.  This is a related issue, but not a dup.

Reporter, if you are really seeing the NOFRAMES text, that is actually correct
according to the spec.  I'm surprised if you are, because it doesn't happen for
anyone else.  What build are you using?
Comment 7 Günni 2002-08-01 08:14:34 PDT
Bill: I do see "This is testing text in the body tag. This is test text in the
noframes tag." I am using 1.0 build 2002053012.
This is perfectly correct. However when this page is viewed as part of a
frameset I should not see the second part. That is the problem.
Comment 8 Bill Mason 2002-08-01 09:32:42 PDT
Ok, then going back to your URL that you supplied, when I view that frameset it
WFM in 2002072204 PC/Win98.  I do not see the NOFRAMES content.  Gunni, if you
update to a current build, does this problem persist?

Updating bug summary to clarify the issue at hand.  Removed testcase kw since
this testcase really doesn't address the issue.
Comment 9 Thiemo Nagel 2002-08-01 11:35:28 PDT
Text enclosed by noframe should *never* appear in Mozilla, since Mozilla
supports frames... I think you got that wrong in comment 6, Bill.

otherwise: wfm on 2002072508 on winxp
Comment 10 Bill Mason 2002-08-01 11:55:23 PDT
Referencing comment 9: as I said, if you read the 4.01 spec there is a specific
case cited in the spec where the <noframe> content should be visible.  See my
quote in comment 5.  The fact that Mozilla does not do it is what bug 47658 is
all about.

This bug however is not about that issue.  I thought initially it was since the
bug description was not clear and the comments that followed confused me as well.
Comment 11 Richard Brodie 2002-08-01 12:28:53 PDT
I imagine that the patch to bug 134401 fixed this.

One could argue make a case for ignoring the example in the HTML standard as 
the rest of the text doesn't seem to support it, or interpret the rest of the 
text in the light of it as Bill (and others) have done.

I doubt we will agree which is correct...
Comment 12 Thiemo Nagel 2002-08-02 09:07:12 PDT
Sorry to Bill and thanks to Richard for making it clear.

"User agents that support frames must only display the contents of a NOFRAMES
declaration when configured not to display frames."

versus

"NOFRAMES may be used, for example, in a document that is the source of a frame
and that uses the transitional DTD. This allows authors to explain the
document's purpose in cases when it is viewed out of the frameset or with a user
agent that doesn't support frames."

I sent an email about this issue to www-html-editor@w3.org which is the proper
place to send in errata of HTML Specifications according to the spec itself.
Comment 13 Thiemo Nagel 2002-08-02 09:29:39 PDT
That is the reply... It's their "bugzilla". I'll keep you posted, if I get any
updates.


Your issue has been added to the W3C's HTML Working Group Issue Tracking System.

If you have further information about this issue to report, please reply to
this message so that the additional data can be automatically attached to the
original query.

If you would like to check on the status of this issue, select the following
link:

http://hades.mn.aptest.com/cgi-bin/voyager-issues?selectid=719    

This link will take you to a page that shows all the categories of problems
tracked in the system.  The category in which your problem report is held
(initially called Incoming) will have the number "1" next to it, and all
others will have the number "0". Select the link to the category to see your
problem report, its status, any follow-up messqages, etc.

If you would like to check on the other issues in the
system, you can do so via the web at http://hades.mn.aptest.com/voyager-issues
Comment 14 Ian Neal 2002-08-13 10:01:36 PDT
Does this bug need to be kept open, if so is there a better component for it to
be in and can it be confirmed? Otherwise it probably just needs marking as WFM
Comment 15 Thiemo Nagel 2002-08-13 10:32:00 PDT
well, it is WFM on build 2002081018, winxp

does anybody still see the bug on a recent build?
Comment 16 Bob Clary [:bc:] 2002-08-20 14:30:19 PDT
the page in the url has been updated to use a frameset doctype, so before you
wfm this bug you should get a test case which tests the reported bug. attachment
93574 [details] doesn't quite test a frameset page with noframes and a transitional doctype.
Comment 17 Bob Clary [:bc:] 2002-08-20 14:34:33 PDT
Created attachment 96066 [details]
testcase 2

modified version of http://selfhtml.teamone.de/html/frames/anzeige/frames2.htm
with transitional doctype with no uri.
Comment 18 John Keiser (jkeiser) 2002-12-09 14:05:22 PST
Yep, WFM WinXP 2002120608.  This was a dup anyway.

Note You need to log in before you can comment on or make changes to this bug.