Closed Bug 1605471 Opened 2 years ago Closed 2 years ago

Update cubeb-coreaudio to acb90e9

Categories

(Core :: Audio/Video: cubeb, task, P2)

Unspecified
macOS
task

Tracking

()

RESOLVED FIXED
mozilla73
Tracking Status
firefox73 --- fixed

People

(Reporter: chunmin, Assigned: chunmin)

References

Details

Attachments

(1 file, 1 obsolete file)

Pick commits:

acb90e9 - Add license for mixer crate
82e7ff9 - Move criterion crate to [dev-dependencies]
f8b7d96 - Implement a new any-to-any mixer (#23)
ae43813 - Remove the test_set_channel_layout_input (#32)
9d0a0e8 - Improve device switch tests (#14)
833a062 - Enable test_ops_stream_register_device_changed_callback (#33)

Summary: Update cubeb-coreaudio to f8b7d96 → Update cubeb-coreaudio to 82e7ff9

Hi Mike,

I have problem when updating the cubeb-coreaudio to version 82e7ff989a1021199b119120be8291fe1dc27ed8. I've updated cubeb-coreaudio's rev to 82e7ff989a1021199b119120be8291fe1dc27ed8 in toolkit/library/rust/shared/Cargo.toml but the third_party/rust/cubeb-coreaudio didn't update its code to the version 82e7ff989a1021199b119120be8291fe1dc27ed8 on github by running cargo update -p gkrust-shared && ./mach vendor rust --ignore-modified or cargo update -p cubeb-coreaudio && ./mach vendor rust

The only updaed code is in D58056. It's the same way when I update the cubeb-coreaudio in bug 1603761 but I don't know why this doesn't work anymore.

Do you have any idea about how to update the code properly?

Flags: needinfo?(mh+mozilla)
Blocks: 1468381
Blocks: 1552928

The reason why vendor doesn't work is in the log if you look closely (I have to admit it's not visible enough):

 0:56.01 package mixer does not provide a license
Flags: needinfo?(mh+mozilla)

Pick commits:
acb90e9 - Add license for mixer crate
82e7ff9 - Move criterion crate to [dev-dependencies]
f8b7d96 - Implement a new any-to-any mixer (#23)
ae43813 - Remove the test_set_channel_layout_input (#32)
9d0a0e8 - Improve device switch tests (#14)
833a062 - Enable test_ops_stream_register_device_changed_callback (#33)

(In reply to Mike Hommey [:glandium] (high latency) from comment #3)

The reason why vendor doesn't work is in the log if you look closely (I have to admit it's not visible enough):

 0:56.01 package mixer does not provide a license

Thanks a bunch!

Summary: Update cubeb-coreaudio to 82e7ff9 → Update cubeb-coreaudio to acb90e9
Attachment #9117383 - Attachment is obsolete: true
Pushed by rmaries@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/eaa23cb3b396
Update cubeb-coreaudio to acb90e9. r=alwu
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
Regressions: 1613156
You need to log in before you can comment on or make changes to this bug.