Closed Bug 1605515 Opened 5 years ago Closed 1 year ago

Intermittent toolkit/components/extensions/test/mochitest/test_ext_webrequest_hsts.html | undefined - Expected: onHeadersReceived, Actual: onResponseStarted

Categories

(WebExtensions :: General, defect, P5)

defect
Points:
2

Tracking

(firefox-esr102 disabled, firefox110 disabled, firefox111 disabled, firefox112 fixed)

RESOLVED FIXED
112 Branch
Tracking Status
firefox-esr102 --- disabled
firefox110 --- disabled
firefox111 --- disabled
firefox112 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: robwu)

References

(Regression)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell disabled][addons-jira])

Attachments

(2 files)

Filed by: nbeleuzu [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=282174556&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/NnmC1peJTXG-ZtJdIlK_UQ/runs/0/artifacts/public/logs/live_backing.log


[task 2019-12-20T23:03:30.633Z] 23:03:30 INFO - TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_webrequest_hsts.html | undefined - Expected: onSendHeaders, Actual: onSendHeaders
[task 2019-12-20T23:03:30.639Z] 23:03:30 INFO - Buffered messages finished
[task 2019-12-20T23:03:30.639Z] 23:03:30 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/mochitest/test_ext_webrequest_hsts.html | undefined - Expected: onHeadersReceived, Actual: onResponseStarted
[task 2019-12-20T23:03:30.640Z] 23:03:30 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:277:18
[task 2019-12-20T23:03:30.640Z] 23:03:30 INFO - testHandler@SimpleTest/ExtensionTestUtils.js:59:18
[task 2019-12-20T23:03:30.640Z] 23:03:30 INFO - testResult@SimpleTest/ExtensionTestUtils.js:73:18
[task 2019-12-20T23:03:30.640Z] 23:03:30 INFO - AsyncExtensionTestUtils.loadExtension@SimpleTest/ExtensionTestUtils.js:105:33
[task 2019-12-20T23:03:30.640Z] 23:03:30 INFO - getExtension@toolkit/components/extensions/test/mochitest/test_ext_webrequest_hsts.html:112:29
[task 2019-12-20T23:03:30.640Z] 23:03:30 INFO - test_hsts_request@toolkit/components/extensions/test/mochitest/test_ext_webrequest_hsts.html:122:19
[task 2019-12-20T23:03:30.640Z] 23:03:30 INFO - nextTick/<@SimpleTest/SimpleTest.js:1800:34
[task 2019-12-20T23:03:30.640Z] 23:03:30 INFO - nextTick@SimpleTest/SimpleTest.js:1816:11
[task 2019-12-20T23:03:30.640Z] 23:03:30 INFO - setTimeout handler
SimpleTest_setTimeoutShim@SimpleTest/SimpleTest.js:689:43
[task 2019-12-20T23:03:30.640Z] 23:03:30 INFO - add_task@SimpleTest/SimpleTest.js:1760:17
[task 2019-12-20T23:03:30.640Z] 23:03:30 INFO - @toolkit/components/extensions/test/mochitest/test_ext_webrequest_hsts.html:119:9
[task 2019-12-20T23:03:30.641Z] 23:03:30 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-12-20T23:03:30.641Z] 23:03:30 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/mochitest/test_ext_webrequest_hsts.html | undefined - Expected: onResponseStarted, Actual: onCompleted
[task 2019-12-20T23:03:30.641Z] 23:03:30 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:277:18
[task 2019-12-20T23:03:30.641Z] 23:03:30 INFO - testHandler@SimpleTest/ExtensionTestUtils.js:59:18
[task 2019-12-20T23:03:30.641Z] 23:03:30 INFO - testResult@SimpleTest/ExtensionTestUtils.js:73:18
[task 2019-12-20T23:03:30.641Z] 23:03:30 INFO - AsyncExtensionTestUtils.loadExtension@SimpleTest/ExtensionTestUtils.js:105:33
[task 2019-12-20T23:03:30.641Z] 23:03:30 INFO - getExtension@toolkit/components/extensions/test/mochitest/test_ext_webrequest_hsts.html:112:29
[task 2019-12-20T23:03:30.641Z] 23:03:30 INFO - test_hsts_request@toolkit/components/extensions/test/mochitest/test_ext_webrequest_hsts.html:122:19
[task 2019-12-20T23:03:30.641Z] 23:03:30 INFO - nextTick/<@SimpleTest/SimpleTest.js:1800:34
[task 2019-12-20T23:03:30.641Z] 23:03:30 INFO - nextTick@SimpleTest/SimpleTest.js:1816:11
[task 2019-12-20T23:03:30.641Z] 23:03:30 INFO - setTimeout handler
SimpleTest_setTimeoutShim@SimpleTest/SimpleTest.js:689:43
[task 2019-12-20T23:03:30.641Z] 23:03:30 INFO - add_task@SimpleTest/SimpleTest.js:1760:17
[task 2019-12-20T23:03:30.641Z] 23:03:30 INFO - @toolkit/components/extensions/test/mochitest/test_ext_webrequest_hsts.html:119:9
[task 2019-12-20T23:03:30.760Z] 23:03:30 INFO - TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_webrequest_hsts.html | redirection ok

Assignee: nobody → csabou
Status: NEW → ASSIGNED
Regressed by: 1603844
Has Regression Range: --- → yes

It does look like this was caused by bug 1603844, specifically:
https://hg.mozilla.org/integration/autoland/rev/a7ee8fc74f3a03fef0e8fe129b32de640331aa89

this doesn't necessarily change the test, but I think it points out that small changes to the order of how we run tests or manifests will result in some odd failures.

Pushed by cbrindusan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/69bad46cb54f
Disable test_ext_webrequest_hsts.html on mac cause of frequent failures. r=jmaher
Keywords: leave-open
Whiteboard: [stockwell disabled]

Thanks for disabling!

Flags: needinfo?(ahal)
Flags: needinfo?(mixedpuppy)

Looking into this a bit.

Apparently the disabling on android/linux was a mistake from:

https://hg.mozilla.org/mozreview/gecko/rev/449141397a2f4c13969b2c0f13d6f088ee08b542#l2.30

Still looking into why this might fail, I'm unable to repro the failure.

Flags: needinfo?(mixedpuppy)
Points: --- → 2
Severity: normal → S3

... and fix a few other tests that try to clear the cache without
waiting.

Blocks: 1778454
Assignee: csabou → rob
Keywords: leave-open
Whiteboard: [stockwell disabled] → [stockwell disabled][addons-jira]
Pushed by rob@robwu.nl:
https://hg.mozilla.org/integration/autoland/rev/bd792bc32a72
Fix and re-enable test_ext_webrequest_hsts.html r=zombie
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 112 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: