Closed Bug 1605559 Opened 3 years ago Closed 3 years ago

Firefox 71 with Wayland crashes after called with parameter

Categories

(Core :: Widget: Gtk, defect, P3)

71 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1608029

People

(Reporter: office, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:71.0) Gecko/20100101 Firefox/71.0

Steps to reproduce:

  1. Use Firefox on Sway with the Wayland backend enabled: MOZ_ENABLE_WAYLAND=1.

  2. On the command line make Firefox 71 open a URL or an image, for example: firefox test_img.svg.

  3. This will open the website or image fine in Firefox' window, but when switching to that window, Firefox crashes.

Actual results:

Firefox crashes. Here is a crash report that I filed: https://crash-stats.mozilla.org/report/index/d7caa966-c380-40dc-82ce-b4c0e0191209

Expected results:

Don't crash.

I can work around this issue two ways:

  1. Downgrade to Firefox 70.
  2. Use Firefox 71 but enable X11 as the window protocol instead of Wayland with unset MOZ_ENABLE_WAYLAND.

Here's the output of Firefox on the terminal after a crash:

  (firefox:108321): Gdk-WARNING **: 11:08:09.182: (../gtk/gdk/wayland/gdkwindow-wayland.c:810):buffer_release_callback: runtime check failed: (impl->staging_cairo_surface != cairo_surface)

  ExceptionHandler::GenerateDump cloned child 109643

  ExceptionHandler::SendContinueSignalToChild sent continue signal to child

  ExceptionHandler::WaitForContinueSignal waiting for continue signal...

  Exiting due to channel error.

  Exiting due to channel error.

  Exiting due to channel error.

  Exiting due to channel error.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core
Priority: -- → P3

May be a dupe of Bug 1608029

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1608029

I just upgraded to Firefox 73 and can confirm that this bug is fixed, thank you!

(In reply to Matthias Braun from comment #5)

I just upgraded to Firefox 73 and can confirm that this bug is fixed, thank you!

Thanks, but I'm not aware of any fix we did for that, I guess it's caused by system setup / state. Please reopen if you see it again.

You need to log in before you can comment on or make changes to this bug.