Closed Bug 1605655 Opened 2 years ago Closed 2 years ago

Firefox doesn't clear all cached files with Ctrl+F5

Categories

(Core :: Networking, defect)

68 Branch
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: bugzil.la, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.3; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

  • Create a server that serves PDF/ODT files with Cache-Control: public, max-age=864000
  • Put a link on site on the same server,
  • Download the file
  • Change content of the PDF/ODT file
  • Press Ctrl+F5
  • Download the PDF/ODT again.

Actual results:

Firefox shows old version of PDF/ODT file

Expected results:

Firefox should remove all cached files related to the domain and show updated PDF/ODT file.

Blocks: shadowdom
Component: Untriaged → DOM: Core & HTML
Product: Firefox → Core
No longer blocks: shadowdom
Component: DOM: Core & HTML → Networking

Hello Mozira,
Is there a public link for us to validate? Thanks.

Flags: needinfo?(bugzil.la)

For the moment no, because on my server noone (except me) can modify PDF files.

  • Create blank page with only one link to PDF (index.html) <a href="any.pdf">Click</a>
  • Add in .htaccess header "Cache-Control: public, max-age=864000" for all PDFs
  • Put on server any.pdf
  • modify PDF on server, use Ctrl+F5 in browser and click the link (perform several times this action).

It is very easy after installation of EasyPHP on local computer (the domain can be 127.0.0.1 - the bug is also present).

Flags: needinfo?(bugzil.la)

From comment 2, the page you hard refreshed is the page with link, not the download file.

How to "refresh" download files? Another shortcut or should be refresh (removed from cache) all domain files?

Flags: needinfo?(juhsu)

This following SUMO link is the solution to the best of my knowledge.
https://support.mozilla.org/en-US/kb/how-clear-firefox-cache

Thanks for reporting this.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(juhsu)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.