Closed Bug 1605715 Opened 3 years ago Closed 2 years ago

Linux Wayland: Copy and paste in contentediable duplicates line breaks

Categories

(Core :: Widget: Gtk, defect)

71 Branch
Desktop
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1547595

People

(Reporter: 5i13ghzt462u, Unassigned)

References

(Blocks 1 open bug)

Details

Description of problem: Only(!) if Wayland is used, when you copy, paste and copy the same text again, the line breaks are duplicated.

Version-Release number of selected component (if applicable): firefox-71.0-15.fc31

How reproducible: Always.

Steps to Reproduce

  1. Go to https://threema-ch.github.io/compose-area/
  2. Copy:
an example
second paragraph
  1. Paste into message box. You get:
an example
second paragraph

fine.
4. Ctrl+A + Copy that text again.
5. Paste somewhere else or in the same message box (Ctrl+V).

Actual results

You get:

an example

second paragraph

Expected results

You should get

an example
second paragraph

again.

(This is also how it is shown in Xorg.)

Additional info

Wayland, Fedora 31

In production/real example this is a problem in Threema Web. Original issue report at https://github.com/threema-ch/threema-web/issues/944.
Also reported downstream at Fedora's bug tracker: https://bugzilla.redhat.com/show_bug.cgi?id=1786104

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core

I can confirm that this problem occurs under Wayland (tested with Sway), but only when running Firefox in Wayland-Native mode (MOZ_ENABLE_WAYLAND=1), not when using XWayland.

See Also: → 1704175

Seems to be fixed now with Bug 1547595.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.