Current URL replaced when friendly error message is displayed

RESOLVED DUPLICATE of bug 157004

Status

()

RESOLVED DUPLICATE of bug 157004
16 years ago
10 years ago

People

(Reporter: benj, Assigned: radha)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
When the new friendly html error messages are displayed the current url is
replaced, preventing corrections to the url or use of the back arrow to get to
the previous page.

open browser, type asdf in location box, hit enter. This is returned:

The connection was refused when attempting to contact www.asdf.com.
connectionFailure long description goes here.
Try again
Search for this address


The url line is changed to:

chrome://global/content/netError.xhtml?e=connectionFailure&u=http%3A//www.asdf.com/&d=The%20connection%20was%20refused%20when%20attempting%20to%20contact%20www.asdf.com.


The url line should not be changed. The end user may want to correct a type-o.
Also the back arrow goes back two pages instead of to the previous one.
(Reporter)

Comment 1

16 years ago
Here's my version info

Mozilla 1.1b
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020727

Comment 2

16 years ago
If you are using an experimental feature, please keep track of the development
in the proper bug.
Both issues are listed as blocking bug 28586
They are bug 157004 and bug 160548

*** This bug has been marked as a duplicate of 157004 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.