POP/SMTP failure for misconfigured SOCKS server

VERIFIED DUPLICATE of bug 56629

Status

MailNews Core
Networking: POP
--
minor
VERIFIED DUPLICATE of bug 56629
16 years ago
9 years ago

People

(Reporter: nigels, Assigned: Navin Gupta)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPME)

(Reporter)

Description

16 years ago
I recently had a severe problem with my Mozilla mail
not being able to POP or SMTP.  I was getting the error
message:

Could not connect to server foo; the connection was refused.

Turns out I misconfigured Mozilla to use AdSubtract for SOCKS
on localhost:4444.  But it took quite some time to realise that
the SOCKS setting affects POP and SMTP.

Therefore, I would suggest some more helpful diagnostic
message: "the connection was refused.\nPossible problem with
SOCKS configuration." - or something similar.

Updated

15 years ago
QA Contact: sheelar → stephend

*** This bug has been marked as a duplicate of 56629 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.