Crash in some 30 percent of cases when loading java-icq in popup window

RESOLVED WORKSFORME

Status

defect
--
critical
RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: kriskelvin, Unassigned)

Tracking

({crash, top100})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1b) Gecko/20020721
BuildID:    2002072104

When visiting above URL I experience crashes in about one third to half of the
cases. After restart of mozilla and retry sometimes crashes again but I did not
notice more than 2 crashes in a row.

Crash appears while loading java classes in popup window. Feedback agent is
never triggered. 

Experienced this problem with earlier versions too.

Reproducible: Sometimes
Steps to Reproduce:
1. visit mentioned URL with javascript and java on, allow javascript to open
popup-windows
2. sometimes crashes sometimes not


Actual Results:  crash sometimes

Expected Results:  java version of icq starts in popup window, each time
(Reporter)

Updated

17 years ago
Keywords: crash
Which JRE Version do you use ?
(Reporter)

Comment 2

17 years ago
There seems to be a similar bug for Linux: Bug 156968
(Reporter)

Comment 3

17 years ago
Here is my java system information I hope it will do:

acl.read = +
acl.read.default = 
acl.write = +
acl.write.default = 
application.home = d:\PROGRA~2\JAVA\J2RE14~1.0
awt.toolkit = sun.awt.windows.WToolkit
bridge.home = d:\PROGRA~2\JAVA\J2RE14~1.0
browser = sun.plugin
browser.vendor = Sun Microsystems, Inc.
browser.version = 1.1
file.encoding = Cp1252
file.encoding.pkg = sun.io
file.separator = \
file.separator.applet = true
http.agent = Mozilla/4.0 (Windows 98 4.10)
java.awt.graphicsenv = sun.awt.Win32GraphicsEnvironment
java.awt.printerjob = sun.awt.windows.WPrinterJob
java.class.path = d:\PROGRA~2\JAVA\J2RE14~1.0\lib\applet
java.class.version = 48.0
java.class.version.applet = true
java.endorsed.dirs = D:\PROGRAMME\JAVA\J2RE1.4.0\lib\endorsed
java.ext.dirs = D:\PROGRAMME\JAVA\J2RE1.4.0\lib\ext
java.home = d:\PROGRA~2\JAVA\J2RE14~1.0
java.io.tmpdir = C:\WINDOWS\TEMP\
java.library.path =
C:\PROGRAMME\MOZILLA.ORG\MOZILLA;.;C:\WINDOWS\SYSTEM;C:\WINDOWS;C:\Programme\mozilla.org\Mozilla\;C:\WINDOWS;C:\WINDOWS\COMMAND
java.protocol.handler.pkgs = sun.plugin.net.protocol
java.runtime.name = Java(TM) 2 Runtime Environment, Standard Edition
java.runtime.version = 1.4.0-b92
java.specification.name = Java Platform API Specification
java.specification.vendor = Sun Microsystems Inc.
java.specification.version = 1.4
java.util.prefs.PreferencesFactory = java.util.prefs.WindowsPreferencesFactory
java.vendor = Sun Microsystems Inc.
java.vendor.applet = true
java.vendor.url = http://java.sun.com/
java.vendor.url.applet = true
java.vendor.url.bug = http://java.sun.com/cgi-bin/bugreport.cgi
java.version = 1.4.0
java.version.applet = true
java.vm.info = mixed mode
java.vm.name = Java HotSpot(TM) Client VM
java.vm.specification.name = Java Virtual Machine Specification
java.vm.specification.vendor = Sun Microsystems Inc.
java.vm.specification.version = 1.0
java.vm.vendor = Sun Microsystems Inc.
java.vm.version = 1.4.0-b92
javaplugin.console = hide
javaplugin.debug.mode = false
javaplugin.enabled = true
javaplugin.exception = false
javaplugin.jre.path = Default
javaplugin.jre.type = Default
javaplugin.maxHeapSize = 96m
javaplugin.nodotversion = 140
javaplugin.proxy.config.type = browser
javaplugin.proxy.usebrowsersettings = true
javaplugin.version = 1.4.0
line.separator = \r\n
line.separator.applet = true
os.arch = x86
os.arch.applet = true
os.name = Windows 98
os.name.applet = true
os.version = 4.10
os.version.applet = true
package.restrict.access.netscape = false
package.restrict.access.sun = true
package.restrict.definition.java = true
package.restrict.definition.netscape = true
package.restrict.definition.sun = true
path.separator = ;
path.separator.applet = true
sun.arch.data.model = 32
sun.boot.class.path =
D:\PROGRAMME\JAVA\J2RE1.4.0\lib\rt.jar;D:\PROGRAMME\JAVA\J2RE1.4.0\lib\i18n.jar;D:\PROGRAMME\JAVA\J2RE1.4.0\lib\sunrsasign.jar;D:\PROGRAMME\JAVA\J2RE1.4.0\lib\jsse.jar;D:\PROGRAMME\JAVA\J2RE1.4.0\lib\jce.jar;D:\PROGRAMME\JAVA\J2RE1.4.0\lib\charsets.jar;D:\PROGRAMME\JAVA\J2RE1.4.0\classes;d:\PROGRA~2\JAVA\J2RE14~1.0\lib\jaws.jar;d:\PROGRA~2\JAVA\J2RE14~1.0\lib\rt.jar;d:\PROGRA~2\JAVA\J2RE14~1.0\lib\charsets.jar;d:\PROGRA~2\JAVA\J2RE14~1.0\lib\jce.jar;d:\PROGRA~2\JAVA\J2RE14~1.0\lib\jsse.jar;d:\PROGRA~2\JAVA\J2RE14~1.0\lib\jaws.jar;d:\PROGRA~2\JAVA\J2RE14~1.0\lib\sunrsasign.jar
sun.boot.library.path = D:\PROGRAMME\JAVA\J2RE1.4.0\bin
sun.cpu.endian = little
sun.cpu.isalist = pentium i486 i386
sun.io.unicode.encoding = UnicodeLittle
sun.java2d.fontpath = 
sun.os.patch.level =  
trustProxy = true
user.country = DE
user.dir = C:\PROGRAMME\MOZILLA.ORG\MOZILLA
user.home = C:\WINDOWS
user.language = de
user.name = unknown
user.timezone = Europe/Berlin
user.variant = 
-> Oji
Assignee: Matti → joe.chou
Component: Browser-General → OJI
QA Contact: asa → pmac
*** Bug 156968 has been marked as a duplicate of this bug. ***
Can you please update to JRE1.4.0_01 ?
(Reporter)

Comment 7

17 years ago
updated to 
java.vm.version = 1.4.0_01-b03

still crashes

Comment 8

17 years ago
*** Bug 152152 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 9

17 years ago
Most probably as a sideeffect of updating to newest Java-Version (because I did
not change other things) Mozilla got very unstable with many crashes a day on my
system (reporter). Aparantly as soon as Java is involved in more than one
window, but I am still not quite sure about that.

Sample windows-crash data:

MOZILLA verursachte einen Fehler durch eine ungültige Seite
in Modul KERNEL32.DLL bei 015f:bff87eb5.
Register:
EAX=c0030058 CS=015f EIP=bff87eb5 EFLGS=00010212
EBX=0064fbc0 SS=0167 ESP=0054ffa8 EBP=00550014
ECX=005501c8 DS=0167 ESI=8188a540 FS=3bef
EDX=bff76859 ES=0167 EDI=005501f0 GS=0000
Bytes bei CS:EIP:
53 56 57 8b 30 83 7d 10 01 8b 4e 38 89 4d f8 75 

Presently I can reproducably crash Mozilla by doing the following:

1. I visit my net radio station which java-starts real-player 
Address: http://www.unionradio.com.ve/audio/onda/Real_vivo.htm
2. I open a new tab (new window might "work" as well)
3. In new tab I visit the icq-page which is topic here

The interesting thing is: Mozilla crashes everytime and immediately even before
seeing the icq-page-content or the popup-window and of course before java starts
in the popup window, very confusing. I encoutered many other crashes concerning
pages with quicktime plugin since yesterday. Before on my system Mozilla was
stable like a rock.

Maybe I should file a new bug about all this but I want you to know about it
around here. Somehow it seems related.

Comment 10

17 years ago
Habe das gleiche Problem.... Mozilla 0.9.8
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204
(Reporter)

Comment 11

17 years ago
Problem still present with Build 2002081419

Comment 12

17 years ago
Problem is still present in the actual 1.1 release (build 20020826/Linux). It
could be an issue for the next release notes as it appears on several other
websites using Java-plugins. In my tests, mozilla crashes on nearly *every*
website using Java-plugins

Comment 13

17 years ago
Re-assign to Nidheesh.
Assignee: joe.chou → nidheesh

Comment 14

17 years ago
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: nidheesh → petersen
Status: UNCONFIRMED → NEW
fixing small error for pmac@netscape.com (filter with : SPAMMAILSUCKS)
Assignee: petersen → joe.chou
QA Contact: pmac → petersen

Comment 16

17 years ago
it can't be reproduced on 
Java(TM) Plug-in: Version 1.4.2
Using JRE version 1.4.2-beta Java HotSpot(TM) Client VM
and 
Mozilla 1.2b
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021115
Assignee: joe.chou → joshua.xia
Status: NEW → UNCONFIRMED

Comment 17

16 years ago
This bug is present in Linux as well. System:
AMD K6-2 500
256 Mb
Mandrake 9, custom 2.4.19 kernel
Mozilla 1.3b (downloaded and installed last night)
J2RE 1.4.1 SE

ICQ2Go crashes 100% of the time while loading applet. 

Most other Java sites work OK, exception being Yahoo Groups chat applets.

Any more info needed, mail me.

Comment 18

16 years ago
Confirming -> ALL/ALL based on dupes and comment 17
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 98 → All
Hardware: PC → All

Comment 19

16 years ago
Another site casing the same crash:
http://www.smh.com.au/entertainment/puzzles/index.html

After page loads, clicking on link to access teh quick crossword (and I would
guess any other crossword) causes Mozilla 1.3b to crash. Also affects Netscape 7.02

Comment 20

16 years ago
can't reproduce this bug on:

Java Plugin 1.4.1_01 and Mozilla 1.4a (Mozilla/5.0 (Windows; U; Windows NT 5.0;
en-US; rv:1.4a) Gecko/20030310).

Comment 21

16 years ago
Still crashing with build 20030312 (Mozilla 1.3) and Java plugin 1.4.1_02-b06 on
Linux

Comment 22

16 years ago
not crash on Mozilla 1.5a
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030623
+
jre1.4.2 build 27
but reload this page, the popup window with java hang
Status: NEW → ASSIGNED

Comment 23

16 years ago
Xiaobin,
Please check this bug because it also happen on IE6 + JRE1.4.2 build 27.

The latest status is no crash happen, but when reload http://go.icq.com/, can't
input on the popup window (which embeded Applet) 

there are some exception display on java console window:
java.lang.IllegalArgumentException: null source
	at java.util.EventObject.<init>(Unknown Source)
	at java.awt.AWTEvent.<init>(Unknown Source)
	at java.awt.event.ComponentEvent.<init>(Unknown Source)
	at java.awt.event.WindowEvent.<init>(Unknown Source)
	at java.awt.event.WindowEvent.<init>(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.SequencedEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)


Thanks!

Comment 24

16 years ago
->kyle
Assignee: joshua.xia → kyle.yuan
Status: ASSIGNED → NEW

Updated

15 years ago
Keywords: top100

Comment 25

14 years ago
is anybody still seeing the crash?

Updated

14 years ago
Assignee: yuanyi21 → pete.zha
(In reply to comment #25)
> is anybody still seeing the crash?

I just tried to reproduce the bug, using Mozilla Firefox 1.5 beta 2 with a new
profile and Sun's JRE 1.5.0_04 under Windows XP SP2. I have not experienced any
crashes. However, I have seen conflicts with some extensions (Mouse Gestures in
particular, which has led to the opening of bug 308799).

Comment 27

14 years ago
Now it seems to work... testet 11.10.2005

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050715 Firefox/1.0.6
SUSE/1.0.6-4.1

Thanks a lot 

:-)

Patrick Liechti

Comment 28

13 years ago
mass reassign to Alfred
Assignee: zhayupeng → alfred.peng

Updated

13 years ago
Blocks: 353557

Updated

13 years ago
No longer blocks: 353557
WFM as well
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20081222 Shiretoko/3.1b3pre
Assignee: alfred.peng → nobody
Status: NEW → RESOLVED
Last Resolved: 11 years ago
QA Contact: chrispetersen → java.oji
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.