Closed Bug 1606941 Opened 2 years ago Closed 2 years ago

[Wayland] Graphics hardware info in about:support partly broken

Categories

(Core :: Widget: Gtk, defect, P2)

Unspecified
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla73
Tracking Status
firefox-esr68 --- unaffected
firefox71 --- unaffected
firefox72 --- unaffected
firefox73 --- fixed

People

(Reporter: viktor_jaegerskuepper, Assigned: unrelentingtech)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

OS: Arch Linux (with Mesa 19.3.1)

In about:support some graphics hardware information is incorrectly displayed when the Wayland backend is used. With mozregression I found that bug 1556301 is the reason.

Broken:
Vendor ID (now listed as X.Org)
Device ID (now the same as "Description")
RAM (now just "0")

Additionally the information about the display resolution (together with display count) is no longer listed.

Most importantly this breaks the WebRender qualification decision because it now leads to "Unsupported vendor".

Blocks: wayland, wr-linux
Regressed by: 1556301

Greg, any idea here?
Thanks.

Flags: needinfo?(greg)
Priority: -- → P2

WebRender qualification needs actual GPU vendor info.
It's currently only available through GLX
(eglQueryRendererIntegerMESA is not available yet)
so let's only use the Wayland native path for non-Xwayland systems for now.

Assignee: nobody → greg

Fine, let's prefer GLX for testing for now. With D58656, the test still works without Xwayland, but everything should be as it was before if you do have a DISPLAY from Xwayland.

Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2080b0fc5766
prefer GLX in glxtest for now r=stransky
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73

argh I swear "clear needinfo" was checked when I wrote that last comment, why did it remain

Flags: needinfo?(greg)

Thanks a lot Greg!

You need to log in before you can comment on or make changes to this bug.