Closed Bug 1607121 Opened 5 months ago Closed 5 months ago

TypeError: environment can only contain strings

Categories

(Testing :: web-platform-tests, defect, P2)

Version 3
defect

Tracking

(firefox74 fixed)

RESOLVED FIXED
mozilla74
Tracking Status
firefox74 --- fixed

People

(Reporter: birtles, Assigned: jgraham)

References

Details

Attachments

(2 files)

Attached file wpt.log

Running ./mach wpt ... on Windows gives me TypeError: environment can only contain strings but it previously used to work. Log attached.

Being on Japanese Windows it's entirely possible I have some non-Latin characters in environment variables but I don't see which ones yet.

Bug 1603557 describes some similar circumstances.

Perhaps certutil needs to use env=ensure_subprocess_env(env)?

I'm not entirely sure if this is a regression or not since although it used to work, it's possible it's my environment that has changed.

I'm going to switch to writing a Gecko-specific crashtest for now and update to a wpt crashtest later once I can get this to run.

Assignee: nobody → james
Status: NEW → ASSIGNED

I ported the ensure_subprocess_env function to wpt; can you test if it actually solves the issue for you?

Flags: needinfo?(brian)
Priority: -- → P2

(In reply to James Graham [:jgraham] from comment #2)

I ported the ensure_subprocess_env function to wpt; can you test if it actually solves the issue for you?

Yes, that works! Thank you!

Flags: needinfo?(brian)
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/autoland/rev/c900ade874f7
Ensure that subprocess environments use correct datatype, r=ato
Failed to create upstream wpt PR due to merge conflicts. This requires fixup from a wpt sync admin.
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/21067 for changes under testing/web-platform/tests
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74
Upstream PR merged by jgraham
Flags: needinfo?(james)

marmedelama points out the following (https://github.com/web-platform-tests/wpt/commit/7a99c5628fa0729330eea64af452ae4c5f93598e#r36904078):

six.ensure_string does not exist, but six.ensure_str does I think its just a typo but code seems to be commited by a bot. Should i fix it "manually" or does it need to be fixed upstream?

Flags: needinfo?(james)

Commented on the PR; fixes anywhere are acceptable.

Flags: needinfo?(james)
You need to log in before you can comment on or make changes to this bug.