[RFE] add favicon (site icon) to proxy icon, tabs, bookmarks, menus

VERIFIED FIXED

Status

Camino Graveyard
Bookmarks
--
enhancement
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Simon Fraser)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
rfe for adding favicons (page icons) to the tab widget.

having a favicon might come in handy for bugs 160722 and 160723, if the favicon
also had the same abilities as the proxy icon in the Location (urlbar) field,
wrt drag'n'drop.
(Reporter)

Comment 1

16 years ago
see also bug 160726.

also, if a given page doesn't have its own favicon, we could default to using
the current page/listing icon.

Comment 2

16 years ago
Page icons (MS terminology: favicons) do show up on tabs in Mozilla 1.1b
2002-07-22-03 Mac OS X (and also in the release version). What am I missing here?
(Assignee)

Comment 3

16 years ago
You're missing the fact that Product = Chimera.

Updated

16 years ago
Summary: add favicon (page icon) to tabs → [RFE] add favicon (page icon) to tabs
(Assignee)

Comment 4

16 years ago
Taking
Assignee: saari → sfraser
(Assignee)

Comment 5

16 years ago
Created attachment 95305 [details] [diff] [review]
Diff for favicons in tabs, bookmarks, proxy icon

Almost ready patch. Need to add some pref control of the feature.
(Assignee)

Comment 6

16 years ago
*** Bug 160726 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

16 years ago
Summary: [RFE] add favicon (page icon) to tabs → [RFE] add favicon (page icon) to proxy icon, tabs, bookmarks, menus
(Assignee)

Comment 7

16 years ago
Checked in last week.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

16 years ago
vrfy'd fixed using 2002.08.21.05 bits. checked site icons (favicons) for the
following basic areas:

* tabbed browser
* proxy icon in urlbar
* bookmarks toplevel menu
* bookmarks sidebar

remaining issues have been filed separately...
Status: RESOLVED → VERIFIED
Summary: [RFE] add favicon (page icon) to proxy icon, tabs, bookmarks, menus → [RFE] add favicon (site icon) to proxy icon, tabs, bookmarks, menus
You need to log in before you can comment on or make changes to this bug.