Closed Bug 1607404 Opened 1 year ago Closed 1 year ago

Firefox on Wayland: UI Offsets

Categories

(Core :: Widget: Gtk, defect, P3)

71 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla74
Tracking Status
firefox74 --- fixed

People

(Reporter: marius.hasselbach, Assigned: jhorak)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:71.0) Gecko/20100101 Firefox/71.0

Steps to reproduce:

  1. Install Firefox on Fedora 31 Workstation (GNOME), which uses Firefox on Wayland by default (https://fedoramagazine.org/firefox-tips-for-fedora-31/).

  2. customize the Firefox UI such that UI elements like Downloads icon, addon icons with submenu etc. to the left of the URL bar.

  3. Try to interact with UI elements placed left to the URL bar.

Check this Bug report for further details:
https://github.com/hackademix/noscript/issues/112

I also filed a bug for Fedora here:
https://bugzilla.redhat.com/show_bug.cgi?id=1782704

Actual results:

hackademix (https://github.com/hackademix) and myself experience an offset between were the mouse pointer actually is and where is gets located on the UI.

Thus the UI is not usable

Expected results:

One sould be able to use the UI, with no offset between mouse pointer UI.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core
Blocks: wayland
Priority: -- → P3
Assignee: nobody → jhorak
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1588200
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f4bba00d59ce
Update mBounds when gdk_window_move_to_rect returns different position/size; r=stransky
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74
Duplicate of this bug: 1588200

I just tested Firefox Nightly 74.0a1 (2020-01-16) (64-bit) and can acknowledge that this regression got fixed for me (Fedora 31 GNOME on Wayland) .
Thanks a lot!

Regressions: 1645695
You need to log in before you can comment on or make changes to this bug.