Closed Bug 1607759 Opened 3 years ago Closed 3 years ago

Middle mouse button scrolling is broken in about:addons page - it gets stuck!. And also affected to Web page using frameset -frame webpage

Categories

(Core :: Layout: Scrolling and Overflow, defect, P1)

73 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1606108
Tracking Status
firefox-esr68 --- unaffected
firefox72 --- unaffected
firefox73 + fixed
firefox74 + fixed

People

(Reporter: juraj.masiar, Unassigned)

References

(Regression)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:73.0) Gecko/20100101 Firefox/73.0

Steps to reproduce:

  1. open addons page: "about:addons" (ctrl + shift + a)
  2. use middle mouse button to scroll down / up
  3. release the button

Actual results:

It's stuck! Like if the button is being still pressed.

Expected results:

It should not get stuck.

Affected versions are only new Beta and Nigtly:
73.0b2 (64-bit)
74.0a1 (2020-01-08) (64-bit)
Tested on Window 10

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit

needinfo myself to test when I'm at a Windows PC with a mouse.

Flags: needinfo?(mstriemer)

(In reply to Mark Striemer [:mstriemer] from comment #2)

needinfo myself to test when I'm at a Windows PC with a mouse.

Did you know that for exactly this kind of use-cases I've implemented "Send Note to Device" addon? :)
(sorry about the off-topic I just couldn't not mention it :))

Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Ever confirmed: true
Keywords: regression
Regressed by: 1597765

[Tracking Requested - why for this release]: Autoscroll would not stop on about:addons and web page using frameset - frame

STR of frameset page:

  1. Open http://www.din.or.jp/~hagi3/JavaScript/JSTips/Default.htm
  2. Click "はじめに" link of the left-hand pane
  3. Middle click to start autscroll at the right-hand pane
  4. Middle click to stop autoscroll
  5. Move mouse
Component: Add-ons Manager → Layout: Scrolling and Overflow
Product: Toolkit → Core
Summary: Middle mouse button scrolling is broken in about:addons page - it gets stuck! → Middle mouse button scrolling is broken in about:addons page - it gets stuck!. And also affeced to Web page using frameset -frame webpage
See Also: → 1606108
Summary: Middle mouse button scrolling is broken in about:addons page - it gets stuck!. And also affeced to Web page using frameset -frame webpage → Middle mouse button scrolling is broken in about:addons page - it gets stuck!. And also affected to Web page using frameset -frame webpage
See Also: → 1607927

Alexander, could you take a look at this?

Flags: needinfo?(surkov.alexander)
Priority: -- → P3

Changing the priority to p1 as the bug is tracked by a release manager for the current beta.
See What Do You Triage for more information

Priority: P3 → P1

works with me, I suspect bug 1606108 fixed the issue, marking as a dupe

Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(surkov.alexander)
Resolution: --- → DUPLICATE
Duplicate of bug: 1606108
Flags: needinfo?(mstriemer)
You need to log in before you can comment on or make changes to this bug.