Closed Bug 1608668 Opened 1 year ago Closed 1 year ago

Nightly 2020-01-11 breaks tree style tabs

Categories

(Firefox :: Extension Compatibility, defect)

74 Branch
Desktop
All
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox74 + fixed

People

(Reporter: shuhao, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Tree style tabs no longer shows up when clicked from the toolbar.

Exception on browser console:

[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIControllers.removeController]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://global/content/elements/browser-custom-element.js :: destroy :: line 1374" data: no] browser-custom-element.js:1374:28
destroy chrome://global/content/elements/browser-custom-element.js:1374
disconnectedCallback chrome://global/content/elements/browser-custom-element.js:408
destroy resource:///modules/ExtensionPopups.jsm:142
(Async: promise callback)
destroy resource:///modules/ExtensionPopups.jsm:139
destroy resource:///modules/ExtensionPopups.jsm:677
clearPopup chrome://browser/content/parent/ext-browserAction.js:498
handleEvent chrome://browser/content/parent/ext-browserAction.js:397
onmouseout chrome://browser/content/parent/ext-browserAction.js:201
(Async: EventHandlerNonNull)
onCreated chrome://browser/content/parent/ext-browserAction.js:201
aEventName resource:///modules/CustomizableUI.jsm:2864
buildWidget resource:///modules/CustomizableUI.jsm:1786
getWidgetNode resource:///modules/CustomizableUI.jsm:1165
insertNodeInWindow resource:///modules/CustomizableUI.jsm:1431
insertNode resource:///modules/CustomizableUI.jsm:1414
onWidgetAdded resource:///modules/CustomizableUI.jsm:1204
notifyListeners resource:///modules/CustomizableUI.jsm:2519
createWidget resource:///modules/CustomizableUI.jsm:2634
createWidget resource:///modules/CustomizableUI.jsm:3821
build chrome://browser/content/parent/ext-browserAction.js:151
onManifestEntry chrome://browser/content/parent/ext-browserAction.js:138
InterpretGeneratorResume self-hosted:1157
AsyncFunctionNext self-hosted:696
(Async: async)
asyncEmitManifestEntry resource://gre/modules/ExtensionCommon.jsm:1545
AsyncFunctionNext self-hosted:696
(Async: async)
runManifest resource://gre/modules/Extension.jsm:2057
addStartupStatePromise resource://gre/modules/Extension.jsm:1761
addPromise resource://gre/modules/Extension.jsm:2051
runManifest resource://gre/modules/Extension.jsm:2056
startup resource://gre/modules/Extension.jsm:2339
addStartupStatePromise resource://gre/modules/Extension.jsm:1761
startup resource://gre/modules/Extension.jsm:2338
AsyncFunctionNext self-hosted:696
(Async: async)
startup resource://gre/modules/Extension.jsm:1557
callBootstrapMethod resource://gre/modules/addons/XPIProvider.jsm:1791
startup resource://gre/modules/addons/XPIProvider.jsm:1895
startup resource://gre/modules/addons/XPIProvider.jsm:2464
callProvider resource://gre/modules/AddonManager.jsm:215
_startProvider resource://gre/modules/AddonManager.jsm:586
startup resource://gre/modules/AddonManager.jsm:810
startup resource://gre/modules/AddonManager.jsm:3474
observe resource://gre/modules/addonManager.js:87

I'm experiencing this regression on macos too, changing platform to "All". Moving bug to "Extension compatibility" too.

[Tracking Requested - why for this release]: Asking release management to track this regression since it's:
a. a recommended addon on AMO
b. the second appearance addon in terms of number of users[1]

[1] https://addons.mozilla.org/en-US/firefox/search/?category=appearance&sort=recommended%2Cusers&type=extension

Component: General → Extension Compatibility
Keywords: regression
OS: Linux → All

Fixed by https://github.com/piroor/treestyletab/issues/2456, but not on AMO yet. Caused by the removed of uneval in Bug 1565170.

Temporarily workaround for Nightly until the fix with 3.3.3 release gets published on AMO:

  1. Go to about:config
  2. Search for xpinstall.signatures.required and set it to false
  3. Go to https://github.com/piroor/treestyletab/releases and click on the 3.3.3 xpi
  4. Install

When the fix is available on AMO, do not forget to reset xpinstall.signatures.required

3.3.4 is now available on AMO and fixes the problem (it includes https://github.com/piroor/treestyletab/commit/f94995bcdf18ba1d4eab08affc9a2ad96c504866)

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.