Closed Bug 1608772 Opened 3 months ago Closed 2 months ago

Enable BigInt <-> i64 interconversion by default in JS shell and Nightly

Categories

(Core :: Javascript: WebAssembly, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla74
Tracking Status
firefox74 --- fixed

People

(Reporter: lth, Assigned: asumu)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(1 file)

The spec is already Phase 3 and we have solid code that needs all the testing it can get, and it's nice to remove the burden of not having interconversion for BigInt values from developers, so we should enable-by-default on the Nightly channel.

Asumu, are you working on this or should I just take care of it? It looks like a small change and it would be nice to land it before the code freeze on Thursday.

Flags: needinfo?(asumu)

Hi Lars, I hadn't worked on it yet since I was working on patching up the inlining for I64 bigints, but I'm happy to take care of it. Will work on it later today.

Flags: needinfo?(asumu)

(In reply to Asumu Takikawa from comment #2)

Hi Lars, I hadn't worked on it yet since I was working on patching up the inlining for I64 bigints, but I'm happy to take care of it. Will work on it later today.

Thanks!

This revision enables the Wasm BigInt<->I64 conversion proposal by default in the JS shell and Nightly.

Some tests are moved around to match the defaults and metadata for WPT wasm tests are set.

The attached patch should enable the flag in the shell and nightly. It also moves around the bigint tests from multiple files that checked failing I64 cases into a new file that's run when the feature is turned off (to avoid overly broad --no-wasm-bigint flag in the options).

Also WPT test failure metadata was set for some I64 tests. The proposal contains some WPT modifications (https://github.com/WebAssembly/JS-BigInt-integration/tree/master/test/js-api) that avoid the failures. Those changes could be merged, but maybe that should come in a separate revision later?

I think the future WPT test changes should be made separately, :ms2ger might be the best person to approve those anyhow. The meta/ workarounds in this patch should be fine for the time being.

Pushed by opoprus@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/22e18a26e3b2
Enable BigInt <-> i64 interconversion by default in JS shell and Nightly r=lth
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74
Regressions: 1613880
You need to log in before you can comment on or make changes to this bug.