Closed Bug 1608800 Opened 3 months ago Closed 3 months ago

[Wayland] Implement DMABUF modifiers

Categories

(Core :: Widget: Gtk, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla74
Tracking Status
firefox74 --- fixed

People

(Reporter: stransky, Assigned: stransky)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Implement DMABUF modifiers and also simplify buffer mapping.

Refactor dmabuf buffer mapping, warn when we're mapping buffer with modifiers.

We need GL texture for WebGL backend.

Depends on D59677

Pushed by nerli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/757d67cba92a
[Wayland] Refactor dmabuf buffer mapping, r=jhorak
https://hg.mozilla.org/integration/autoland/rev/67066c674f24
[Wayland] Implement DMABUF modifiers, r=jhorak
https://hg.mozilla.org/integration/autoland/rev/c447185ced39
[Wayland] Export GL texture from WaylandDMABufSurface class, r=jhorak
Duplicate of this bug: 1588736
You need to log in before you can comment on or make changes to this bug.