Closed Bug 1608863 Opened 11 months ago Closed 11 months ago

Switch to sitespeed.io browsertime

Categories

(Testing :: Raptor, enhancement, P2)

Version 3
enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1607851

People

(Reporter: tarek, Assigned: tarek)

References

(Blocks 1 open bug)

Details

Attachments

(1 obsolete file)

We want to stop using our fork and rely on upstream

Do we want to create a branch on sitespeed.io and use it as a 'stable' branch since master has a lot of activity
even if we pin at a specific version, that could give us the ability to cherry pick fixes if we need to

Flags: needinfo?(rwood)
Flags: needinfo?(nalexander)
Flags: needinfo?(gmierz2)

(In reply to Tarek Ziadé (:tarek) from comment #2)

Do we want to create a branch on sitespeed.io and use it as a 'stable' branch since master has a lot of activity
even if we pin at a specific version, that could give us the ability to cherry pick fixes if we need to

IMO I think having our own 'stable' branch is a good idea so that we have a bit more flexibility.

Flags: needinfo?(rwood)
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1607851
Attachment #9120507 - Attachment is obsolete: true

(In reply to Tarek Ziadé (:tarek) from comment #2)

Do we want to create a branch on sitespeed.io and use it as a 'stable' branch since master has a lot of activity
even if we pin at a specific version, that could give us the ability to cherry pick fixes if we need to

It's technically challenging to do that right now because pointing tools/browsertime/package.lock at a git repo isn't (at least, wasn't) supported with the version of Node/npm/whatever in the toolchain builders. I'm sure we could address that, if we wanted to.

I strongly prefer explicitly bumping the hash in tree; that's the best way to ensure reproducible builds (and to just know where things stand). So I'm -1 on a Mozilla-specific branch that can increment "out from under us".

Flags: needinfo?(nalexander)
Flags: needinfo?(gmierz2)
You need to log in before you can comment on or make changes to this bug.