Text doesn't display italicized when it contains accented characters

VERIFIED WORKSFORME

Status

()

Core
Internationalization
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Greg K., Assigned: Roy Yokoyama)

Tracking

({intl, regression, testcase})

Trunk
PowerPC
Mac System 9.x
intl, regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1b) Gecko/20020803
BuildID:    2002080303

When an HTML I element contains accented characters, no text within the I
element is displayed italicized.

Reproducible: Always
Steps to Reproduce:
1. Access the testcase (to be attached shortly).

Actual Results:  The I element containing only US-ASCII characters italicized,
but the I element containing accented ISO 8859-1 characters didn't.

Expected Results:  Text in both I elements should have been italicized.

I'm not sure why one displays antialiased and the other doesn't, either.
Separate bug?
(Reporter)

Comment 1

16 years ago
Created attachment 93868 [details]
Testcase containing one I element with only US-ASCII text, and another containing accented ISO 8859-1 characters
(Reporter)

Comment 2

16 years ago
Note this bug first appeared in FizzillaCFM/2002080203. It was not in
2002-08-01-03-trunk.
Keywords: testcase
(Reporter)

Comment 3

16 years ago
Reconfirmed using Mac/2002080208/9.2.2. Setting OS to Mac System 9.x.
OS: MacOS X → Mac System 9.x
(Assignee)

Comment 4

16 years ago
I viewed the page on MacOSX and it looks ok (italicized).
ruixu: is it MacOS9 specific?  If so, then please assign to nhotta.
(Reporter)

Comment 5

16 years ago
Created attachment 94042 [details]
Screenshot of testcase in FizzillaCFM/2002080303, using Lucida Grande as default sans-serif font

It sure doesn't work for me using FizzillaCFM/2002080303.

Comment 6

16 years ago
it looks ok on JA MacOS 9.1 with branch build 2002080509.
Keywords: intl
QA Contact: ruixu → ylong

Comment 7

16 years ago
Works for me on 08-05 branch build / Mac 9.2.2.
Notice, the user agent string is for Mac OS X in reporter's original report,
probably on trunk build.  But I don't see it on both branch and trunk build /
Mac 10.1.5..
(Reporter)

Comment 8

16 years ago
Problem is still evident using FizzillaCFM/2002080508.
(Reporter)

Comment 9

16 years ago
See also bug 161555 for a possibly related problem.
rbs?  You touched the mac font code then, no?
(Reporter)

Comment 11

16 years ago
See also bug 161881.

Updated

16 years ago
Keywords: regression
(Reporter)

Comment 12

16 years ago
Any thoughts on this one, rbs@maths.uq.edu.au? It showed up about the same time
MathML went in.

Comment 13

16 years ago
See bug 162221 (Mac OS X, same problem).

Comment 14

16 years ago
Are these bugs still there? They should be gone by now.
(Reporter)

Comment 15

16 years ago
WorksForMe using FizzillaCFM/2002081503. Thanks, rbs@maths.uq.edu.au. Do you
know which bug's fix would have taken care of this?

Comment 16

16 years ago
bug 161481 -- it has shown that the ATSUI fallback has a number of worries.
(Reporter)

Updated

16 years ago
Depends on: 161481
(Reporter)

Comment 17

16 years ago
Resolving WFM per comment 15.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 18

16 years ago
Verified as such.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.