Tabbing from menus to viewport bounces scrolled content back to top

VERIFIED INVALID

Status

()

VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: mark.slater, Assigned: aaronlev)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt; Creative)
BuildID:    2002080104

When a menupoint (for instance the "file" menu) has focus, and you tabbed back 
to a page with long content that you scrolled, it will bounce back to the top.

Reproducible: Always
Steps to Reproduce:
1. Visit www.cnn.com
2. Scroll half-way down
3. Click once on the "File" menupoint, then again to make the file menu 
disappear but to leave the focus on "File"
4. Tab back to viewport

Actual Results:  Scrolled content bounced back to the top of the page

Expected Results:  Page should not have scrolled back up.
that's because, the topmost element on the page get's the focus.
(Reporter)

Comment 2

16 years ago
But surely that's wrong behaviour? If I don't have a mouse, and using only the
keyboard to get around, I don't want my page bouncing around all the time, do I?
Just think if the page is thousands of lines long...

Comment 3

16 years ago
Works for me.  Pressing Tab while a menu is open dismisses the menu without
changing focus.  Pressing Tab while the address bar has focus focuses the
content area without changing the scroll position; you have to press Tab again
to focus the first item on the page.

See also bug 23914.
(Reporter)

Comment 4

16 years ago
Jesse: You didn't quite follow my instructions. Click on a menu point (like
"File" or "Edit"), then click that exact same menu again. The menu point you
clicked will still have focus, you just might not be able to see it. If you then
press tab, the scrolled viewport will jump back up to the first link on that page.

In this respect, Mozilla seems to be doing two different things: Tab from the
focussed menu point: page jumps. Tab from the URL bar: page stays at the same
position.

Comment 5

16 years ago
Clicking twice on a menu does not leave focus on the menu bar.  You can see that
it doesn't by pressing the down key or by moving your mouse away from the menu
bar.  Pressing the Alt key by itself does put focus on the menu bar, and
pressing Tab in that case unfocuses the menu bar without doing anything else
(like pressing Esc).
keyboard nav
Assignee: Matti → aaronl
Component: Browser-General → Keyboard Navigation
QA Contact: asa → sairuh
and invalid per comment 5.  Indeed, the second click re-focuses the main content
area.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
mass-verification of Invalid bugs.

if you don't think the report is invalid, please check to see if it has already
been reported (it might be a duplicate instead). otherwise, make sure that there
are steps (a valid test case) that clearly display the issue as an unexpected
defect.

mail filter string for bugspam: SequoiadendronGiganteum
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.