Closed Bug 1609421 Opened 2 years ago Closed 2 years ago

Intermittent TEST-UNEXPECTED-FAIL | firefox/libxul.so differs. See the diff.html or diff.txt artifact

Categories

(Firefox Build System :: Task Configuration, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1596350

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure)

Filed by: csabou [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=285023079&repo=try
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/N9BcEVTHSmmBYNfz-sOfcg/runs/0/artifacts/public/logs/live_backing.log


[task 2020-01-15T11:55:39.134Z] |###########################| 100% ETA: 0:00:00
[task 2020-01-15T11:56:01.511Z] |###########################| 100% Time: 0:07:09
[task 2020-01-15T11:56:01.511Z] + curl -L -f https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/PBH9BV68QvK2LMHt-ePKcA/artifacts/public/build/target.generated-files.tar.gz
[task 2020-01-15T11:56:01.516Z] % Total % Received % Xferd Average Speed Time Time Time Current
[task 2020-01-15T11:56:01.517Z] Dload Upload Total Spent Left Speed
[task 2020-01-15T11:56:01.517Z]
[task 2020-01-15T11:56:01.622Z] 0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
[task 2020-01-15T11:56:01.622Z] 100 157 100 157 0 0 1495 0 --:--:-- --:--:-- --:--:-- 1495
[task 2020-01-15T11:56:01.743Z]
[task 2020-01-15T11:56:01.743Z] 100 10.8M 100 10.8M 0 0 48.1M 0 --:--:-- --:--:-- --:--:-- 48.1M
[task 2020-01-15T11:56:01.744Z] + curl -L -f https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/QUHvFb9hRomI6GxwJsO3Yw/artifacts/public/build/target.generated-files.tar.gz
[task 2020-01-15T11:56:01.749Z] % Total % Received % Xferd Average Speed Time Time Time Current
[task 2020-01-15T11:56:01.749Z] Dload Upload Total Spent Left Speed
[task 2020-01-15T11:56:01.749Z]
[task 2020-01-15T11:56:01.950Z] 0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
[task 2020-01-15T11:56:01.950Z] 100 157 100 157 0 0 785 0 --:--:-- --:--:-- --:--:-- 785
[task 2020-01-15T11:56:02.069Z]
[task 2020-01-15T11:56:02.069Z] 100 10.8M 100 10.8M 0 0 34.0M 0 --:--:-- --:--:-- --:--:-- 34.0M
[task 2020-01-15T11:56:02.070Z] + HAVE_GENERATED_FILES=1
[task 2020-01-15T11:56:02.070Z] + test -n 1
[task 2020-01-15T11:56:02.070Z] + diffoscope --html generated-files.diff.html --text generated-files.diff.txt --progress --output-empty a.generated-files.tar.gz b.generated-files.tar.gz
[task 2020-01-15T11:56:02.135Z] | | 0% ETA: --:--:--
[task 2020-01-15T11:56:02.135Z] 2020-01-15 11:56:02 W: diffoscope.main: Fuzzy-matching is currently disabled as the "tlsh" module is unavailable.
[task 2020-01-15T11:56:02.175Z] | | 0% ETA: --:--:--
[task 2020-01-15T11:56:02.175Z] |###########################| 100% ETA: 0:00:00
[task 2020-01-15T11:56:02.188Z] |###########################| 100% Time: 0:00:00
[task 2020-01-15T11:56:02.188Z] + report_error diff
[task 2020-01-15T11:56:02.188Z] + python3
[task 2020-01-15T11:56:02.776Z] TEST-UNEXPECTED-FAIL | firefox/libxul.so differs. See the diff.html or diff.txt artifact
[task 2020-01-15T11:56:02.778Z] + fail
[task 2020-01-15T11:56:02.778Z] + exit 1
[taskcluster 2020-01-15 11:56:03.091Z] === Task Finished ===
[taskcluster 2020-01-15 11:56:05.522Z] Unsuccessful task run with exit code: 1 completed in 486.374 seconds

This job doesn't run on beta, but beta-simulation doesn't know that.

And the reason it doesn't run on beta is that there's a known issue, which this is a manifestation of.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(mh+mozilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1596350
Duplicate of this bug: 1610500
You need to log in before you can comment on or make changes to this bug.